Package Details: dvbcut 0.6.1-2

Git Clone URL: https://aur.archlinux.org/dvbcut.git (read-only)
Package Base: dvbcut
Description: Qt3 application for cutting parts out of DVB streams
Upstream URL: http://dvbcut.sourceforge.net/
Licenses: GPL
Submitter: AndyRTR
Maintainer: webmeister
Last Packager: webmeister
Votes: 14
Popularity: 0.202810
First Submitted: 2005-11-23 19:13
Last Updated: 2015-07-05 17:24

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

tinxy commented on 2014-12-13 23:19

@WFCody
Added dvbcut-qt4 to AUR

WFCody commented on 2014-08-02 13:03

There is a Qt4 port here:

https://github.com/nextghost/dvbcut-qt4

llarevo commented on 2013-07-26 17:38

The application crashes when pressing "<" or ">" after installing from this package (hearing sound around cut points fails).

BTW: The sources used here are completely outdated. For generating packages https://dvbcut.svn.sourceforge.net/svnroot/dvbcut/trunk dvbcut should be used.

llarevo commented on 2013-07-26 17:37

The application crashes when pressing "<" or ">" after installing from this package (hearing sound around cut points fails).

BTW: The sources here are completely outdated. For generating packages https://dvbcut.svn.sourceforge.net/svnroot/dvbcut/trunk dvbcut should be used.

llarevo commented on 2013-07-26 17:37

The application crashes when pressing "<" or ">" after installing from this package (hearing sound around cut points fails).

BTW: The sources here are completely outdated. For generating packages https://dvbcut.svn.sourceforge.net/svnroot/dvbcut/trunk dvbcut should be used.

Hidi commented on 2013-04-14 11:48

I got an qimage.h realted error while compiling.

I had to change the ./configure line to this:

./configure --prefix=/usr --with-qt3=/usr/lib/qt3 --with-qt3-include=/usr/include/qt3/

this works!

andreas_baumann commented on 2012-04-14 14:42

There is a missing '#include <unistd.h>" in main.cpp for XXX_FILENO.

Patched at:

http://gitorious.org/aba_arch_aur/aba_arch_aur/trees/master/adapted_packages/dvbcut

Anonymous comment on 2011-05-16 11:33

disowned

There is a new release (bugfixes):
http://www.mail-archive.com/dvbcut-user%40lists.sourceforge.net/msg01233.html

Anonymous comment on 2010-06-22 11:37

The md5sum of the source tarball changes every download. wtf? That was no problem at begin of June.
Anyway, back to version 0.6.0-4.


---
Backup PKGBUILD 0.6.0-5: http://pastebin.org/350680

diode commented on 2010-06-21 20:50

Build on x86_64 failed:

==> Erstelle Paket: dvbcut 0.6.0-5 x86_64 (Mo 21. Jun 22:34:13 CEST 2010)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
-> Lade trunk.tar.gz?view=tar&pathrev=170 herunter...
--2010-06-21 22:34:16-- http://dvbcut.svn.sourceforge.net/viewvc/dvbcut/trunk.tar.gz?view=tar&pathrev=170
.
.
.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: nicht spezifiziert [application/x-gzip]
In »»trunk.tar.gz?view=tar&pathrev=170.part«« speichern.

[ <=> ] 1.019.029 184K/s in 5,8s

2010-06-21 22:34:23 (171 KB/s) - »»trunk.tar.gz?view=tar&pathrev=170.part«« gespeichert [1019029]

==> Überprüfe Gültigkeit der Quell-Dateien mit md5sums...
trunk.tar.gz?view=tar&pathrev=170 ... FEHLGESCHLAGEN
==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung!

Anonymous comment on 2010-06-08 13:03

New PKGBUILD. I changed the source to 'Subversion Revision 170'. Reason:
- Fixes for gcc 4.4 and 4.5 are included
- dvbcut.desktop and icon are included

---
Old PKGBUILD: http://pastebin.org/318408

Anonymous comment on 2010-05-23 11:46

Updated. Thanks everyone for informing me. Special thanks to pquiney, who fixed the problem.

Anonymous comment on 2010-05-22 23:17

Fixed it!

Add the lines below to the PKGBUILD file (below the existing sed lines)

# Fix for compilation error under gcc 4.5 (pquiney)
sed -i 's/index::index/class index/' ${srcdir}/${pkgname}-${pkgver}/src/mpgfile.h
sed -i 's/index::index/class index/' ${srcdir}/${pkgname}-${pkgver}/src/main.cpp

I have emailed the updated PKGBUILD file to the maintainer.

Anonymous comment on 2010-05-22 22:18

Build Fails on x86_64 as well.

Same error several time over, starting with....

In file included from differenceimageprovider.cpp:25:0:
mpgfile.h: At global scope:
mpgfile.h:52:3: error: 'index::index' names the constructor, not the type
mpgfile.h: In member function 'const index::picture& mpgfile::operator[](unsigned int) const':
mpgfile.h:96:12: error: 'idx' was not declared in this scope

harveythedog commented on 2010-05-13 06:36

Build Failed (i686)