Package Details: dvbstreamer 2.1.0-4

Git Clone URL: https://aur.archlinux.org/dvbstreamer.git (read-only)
Package Base: dvbstreamer
Description: console based application to stream DVB/ATSC service(s) over UDP or to a file.
Upstream URL: http://sourceforge.net/projects/dvbstreamer/
Licenses: GPL
Submitter: None
Maintainer: chrisallison
Last Packager: chrisallison
Votes: 10
Popularity: 0.001604
First Submitted: 2008-07-01 05:54
Last Updated: 2015-06-14 06:59

Latest Comments

endre commented on 2016-02-10 09:01

hey guys, it worksforme(tm)

==> Finished making: dvbstreamer 2.1.0-4 (Wed Feb 10 10:01:57 CET 2016)

chrisallison commented on 2016-02-10 08:37

John,
look in the directory where the package build file is. Are the patches there? if not click the link above under sources and put them there and try again.

JohnRobson commented on 2016-02-09 00:02

==> Starting build()...
patch: **** Can't open patch file ../../dvbstreamer-2.1.0-libev4.patch : No such file or directory
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build dvbstreamer.

chrisallison commented on 2014-06-01 13:18

Updated package to include a patch that allows the daemon mode to remove the pid file when exiting.

chrisallison commented on 2014-05-24 02:28

Uploaded new PKGBUILD for latest released version and includes debian libev patch.
Note: new dependencies added.

endre commented on 2013-03-24 21:31

World changes, so does Arch.

kellerman commented on 2013-03-24 20:40

Hey, still cant get it to compile properly with the modified pkgbuild and patch

endre commented on 2011-11-01 00:40

Hey, I have managed to get it working:

==> Finished making: dvbstreamer 2.1.0-1 (Tue Nov 1 01:36:30 CET 2011)

You were right, debian has a working patch for the 1st problem. The solution for the second problem is that 'autoreconf -i' has to be called in before configure. I don't know the actual behaviour of the toolchain so this may not be the proper solution, but worksforme(tm).

Find the 2.1.0 PKGBUILD tarball here: http://end.re/dvbstreamer-2.1.0_PKGBUILD.tar.gz

endre

Anonymous comment on 2011-08-14 21:31

There is a v2.1 release now, which, at the moment doesn't compile under my i386 Arch system. 2 problems,

1st the move from libev v3 to v4, replaces a function call with a macro def and so, configure cannot 'see' the function call now. here is a Debian patch for this problem.

2nd. when compiling, there is a problem with a missing udp.Tpo file, which I am still investigating.

Anonymous comment on 2010-04-21 14:44

This is the new V2 release candidate. Compiles fine on i386, am unable to test on x86_64, so would be grateful if some kind sole would do so for me, thanks.
The author has a short blog post regarding this new release at http://sourceforge.net/apps/wordpress/dvbstreamer/