Package Details: dvdstyler 3.0.4-3

Git Clone URL: https://aur.archlinux.org/dvdstyler.git (read-only)
Package Base: dvdstyler
Description: Cross-platform DVD authoring application
Upstream URL: http://www.dvdstyler.de/
Licenses: GPL
Submitter: xyproto
Maintainer: artafinde
Last Packager: artafinde
Votes: 70
Popularity: 1.586612
First Submitted: 2011-12-14 17:00
Last Updated: 2018-01-28 11:48

Dependencies (16)

Required by (0)

Sources (1)

Latest Comments

nerdnils commented on 2018-01-04 19:43

worked, thank you

migrev commented on 2018-01-04 08:29

@nerdnils: Package is working for me, so can't really reproduce your error. But basically try by recompiling wxsvg first and then dvdstyler. Let's see is that fixes it.

nerdnils commented on 2018-01-04 05:36

Some dependency seems to be missing: dvdstyler: error while loading shared libraries: libwx_gtk2u_webview-3.0.so.0: cannot open shared object file: No such file or directory

But I can't find out which package owns that library. Can somebody help me out?

migrev commented on 2017-12-04 23:18

$ sha1sum DVDStyler-3.0.4.tar.bz2 0ff6de099d177c05c34f536defc1562e520b9703 DVDStyler-3.0.4.tar.bz2

That's the sum included in current PKGBUILD.

joe1984 commented on 2017-12-04 22:17

Can the check-sums be updated in this pkgbuild, please? I get this message when upgrading. ==> Validating source files with sha1sums... DVDStyler-3.0.4.tar.bz2 ... FAILED ==> ERROR: One or more files did not pass the validity check! ==> ERROR: Makepkg was unable to build dvdstyler.

migrev commented on 2017-11-28 22:24

@zoe: They made a silent update keeping the version number. When I updated the package the sed line in the PKGBUILD was needed because configure failed to find wxGTK. They've fixed it upstream (I used 3.0.3 and they are using 3.0.0 but for the same result) without increasing version number, that's why the checksum has changed and the sed line is useless now. Thanks for reporting it. Bumping to 3.0.4-2 to fix the PKGBUILD.

zoe commented on 2017-11-28 20:14

In PKGBUILD, line 26 :
sed -i "s|WX_CONFIG_CHECK(\[3.0\]|WX_CONFIG_CHECK(\[3.0.3\]|" configure.ac
does nothing at all, because in configure.ac, there is (line 65) :
WX_CONFIG_CHECK([3.0.0]
and not :
WX_CONFIG_CHECK([3.0]

Maybe, some update of PKGBUILD is necessary ??……

zoe commented on 2017-11-28 20:03

shasum1 is wrong, not
f703eeacd78186e0070f3cc7e5e67c6e5a5fde19
but
0ff6de099d177c05c34f536defc1562e520b9703

migrev commented on 2017-07-03 10:00

@tombenko: The problem is with package wxsvg. Recompiling it fixes the problem. I will bump it to force a new compile for everyone. Thanks for the info.

tombenko commented on 2017-07-02 21:16

The wxgtk2 package no longer contains libwx-gtk2u-webview shared library, so the package gets unusable.

All comments