Package Details: dxvk-bin 1.3.1-0

Git Clone URL: https://aur.archlinux.org/dxvk-bin.git (read-only)
Package Base: dxvk-bin
Description: A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
Upstream URL: https://github.com/doitsujin/dxvk
Keywords: dxvk
Licenses: zlib/libpng
Conflicts: dxvk-git
Provides: dxvk
Submitter: ssorgatem
Maintainer: ssorgatem
Last Packager: ssorgatem
Votes: 107
Popularity: 11.514301
First Submitted: 2018-03-02 07:39
Last Updated: 2019-07-23 11:12

Pinned Comments

ssorgatem commented on 2018-03-27 06:47

To enable DXVK in a wineprefix, do the following (with the WINEPREFIX variable properly set):

setup_dxvk install

In order to uninstall DXVK from a wineprefix:

setup_dxvk uninstall

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ssorgatem commented on 2019-06-17 20:56

@alexzk it behaves like upstream, which is, by default, it copies the DXVK libraries to your prefix, which means they are not automatically updated when you update the package.

If you want that, use the "--symlink" argument.

Namarrgon commented on 2019-06-15 16:58

$pkgdir needs to be quoted properly or the build will fail in directories that contain whitespace.

alexzk commented on 2019-06-10 21:45

Can you elaborate in pinned comment, if I must repeat 'setup_dxvk install' after package upgrade for each wineprefix i have, or it implies automatically. Because early 0.xx versions were doing copies of itself = need repeat.

grawity commented on 2019-05-25 21:31

The conflict with dxvk-bin<1.0-1 is redundant, as a package already cannot be co-installed with itself... however, it does cause trouble for AUR helpers which don't support versioned deps. It should probably be removed.

ssorgatem commented on 2019-04-16 14:33

No, putting $pkgdir there will break the link when installed.

That whole chmod line needs to be removed. It should be fixed now.

JIgnacioTG commented on 2019-04-16 06:57

I resolved the "chmod: cannot operate on dangling symlink 'setup_dxvk'" bug editing too the PKGBUILD file but adding the variable $pkgdir in the line of the symbolic link:

ln -s $pkgdir/usr/share/dxvk/setup_dxvk.sh "$pkgdir/usr/bin/setup_dxvk"

I don't know if this breaks something.

mallgrab commented on 2019-04-15 23:49

It cries about "chmod: cannot operate on dangling symlink 'setup_dxvk'"
Editing the PKGBUILD and adding "cd $pkgdir/usr/bin"
below "mkdir -p $pkgdir/usr/bin"
fixed the problem for me.

ssorgatem commented on 2019-04-07 16:01

The 1.1 release has been pulled out because it was buggy (reportedly caused GPU hangs), so this package hasn't included it.

Nocifer commented on 2019-03-03 13:04

Hi, is there a reason that this package installs dxvk with the new --without-dxgi flag enabled by default? Or rather, I do understand the reason somewhat (probably so it can work out of the box without breaking synergy with vkd3d, dxup et al) but it's actually not really recommended by the developer because it breaks (or at least underperforms in) many games, especially when one's using an nvidia card. And even worse is that I can't see any way of installing WITH dxgi without modifying the provided script and removing the flag.

I think it'd be preferable if users could choose to install with or without dxgi themselves; maybe by creating a flag in your own script (e.g. --dxgi) which if present would serve to disable the --without-dxgi flag of the upstream script, which could then remain the default as it is now.

damachine commented on 2019-02-26 17:12

@ssorgatem Thanks for your help. have the old setup methode use for now.