Package Details: dxvk-bin 1.2.1-0

Git Clone URL: https://aur.archlinux.org/dxvk-bin.git (read-only)
Package Base: dxvk-bin
Description: A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
Upstream URL: https://github.com/doitsujin/dxvk
Keywords: dxvk
Licenses: zlib/libpng
Conflicts: dxvk-bin<1.0-1, dxvk-git, dxvk-win32-bin, dxvk-win32-bin<1.0-1, dxvk-win64-bin, dxvk-win64-bin<1.0-1, dxvk-win64-git
Provides: dxvk
Submitter: ssorgatem
Maintainer: ssorgatem
Last Packager: ssorgatem
Votes: 91
Popularity: 7.735308
First Submitted: 2018-03-02 07:39
Last Updated: 2019-05-19 18:42

Pinned Comments

ssorgatem commented on 2018-03-27 06:47

To enable DXVK in a wineprefix, do the following (with the WINEPREFIX variable properly set):

setup_dxvk install

In order to uninstall DXVK from a wineprefix:

setup_dxvk uninstall

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

beefsack commented on 2018-06-27 10:44

The new sha256sum appears to be:

$ curl <https://github.com/doitsujin/dxvk/releases/download/v0.60/dxvk-0.60.tar.gz> | sha256sum
4b3c66d3b40086653504b5a06a54cc992063c1aa7886327de84927b944c196f6  -

ssorgatem commented on 2018-06-26 11:47

uh... again?

Oh, it's probably related to the unity build thing.

tuxitop commented on 2018-06-26 11:43

Seems like the released package is changed upstream. Therefore the sha256sum needs to be updated.

ssorgatem commented on 2018-06-25 07:35

@DonHugo indeed. Thanks for spotting that! Fixed.

DonHugo commented on 2018-06-25 07:29

@ssorgatem

Shouldn't the setup part in the pinned comment be

For 32-bit D3D11: setup_dxvk32

For 64-bit D3D11: setup_dxvk64

and the reset argument only for uninstalling?

jcstryker commented on 2018-06-23 01:23

DXVK 0.60 currently requires the vulkan developer branch for NVIDIA cards:

https://github.com/doitsujin/dxvk/issues/433#issuecomment-398647461

https://developer.nvidia.com/vulkan-driver

I have submitted the 'nvidia-vulkan' package to the AUR, based off det's 'nvidia-full-beta', that will download and package the driver from this branch.

ssorgatem commented on 2018-06-22 19:41

Yes, that was the normal pattern, but the new release didn't follow it. So I changed the PKGBUILD for it.

Which worked well this morning.

But now the link is "fixed"... which breaks the PKGBUILD now... I'll update it now.

l33tlinuxh4x0r commented on 2018-06-22 19:30

The pkgbuild for version 0.60 doesn't have the right source file... It should be source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-$pkgver.tar.gz") instead of source=("https://github.com/doitsujin/dxvk/releases/download/v$pkgver/dxvk-v$pkgver.tar.gz")

Enverex commented on 2018-04-15 17:47

Nice one, well done peeps.

cogwerkz commented on 2018-04-13 13:19

@Enverex @ssorgatem Mainainter of wine-staging-pba-git here, and I'm thinking the versioning problem @Enverex is having is in my PKGBUILD, not here and not in pacman.

I'll look into it and get it fixed! :)

Edit: The wine-staging-pga-git package shows the versions of the wine, wine-staging and wine-git replacements it provides now, so hopefully pacman shouldn't complain anymore. Sorry for the trouble it caused!

Edit2: Messed up my sed replacements on that first try, but now it properly extracts the various versions from the extensive versioning string. As of posting this the versions produced by the PKGBUILD are as below, and should function properly with pacman.

wine=3.5.r193.ga7b33a6a42 wine-git=3.5.r193.ga7b33a6a42 wine-pba=3.5.r33.8c72f84 wine-staging=3.5.r13.g3fe54232 wine-wow64=3.5.r193.ga7b33a6a42