Package Details: dxvk-bin 1.2.2-0

Git Clone URL: https://aur.archlinux.org/dxvk-bin.git (read-only)
Package Base: dxvk-bin
Description: A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (Windows DLL binary files)
Upstream URL: https://github.com/doitsujin/dxvk
Keywords: dxvk
Licenses: zlib/libpng
Conflicts: dxvk-bin<1.0-1, dxvk-git, dxvk-win32-bin, dxvk-win32-bin<1.0-1, dxvk-win64-bin, dxvk-win64-bin<1.0-1, dxvk-win64-git
Provides: dxvk
Submitter: ssorgatem
Maintainer: ssorgatem
Last Packager: ssorgatem
Votes: 100
Popularity: 10.035600
First Submitted: 2018-03-02 07:39
Last Updated: 2019-06-17 20:51

Pinned Comments

ssorgatem commented on 2018-03-27 06:47

To enable DXVK in a wineprefix, do the following (with the WINEPREFIX variable properly set):

setup_dxvk install

In order to uninstall DXVK from a wineprefix:

setup_dxvk uninstall

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

WhatTheBuck commented on 2018-03-20 17:36

@ssorgatem I rebuilt wine-vulkan-git right before trying to install this and it still didn't work. Isn't wine-vulkan required for this to work? Could it be because the package version of wine-vulkan-git doesn't appear as 3.4 when installed?

The "about" tab in winecfg lists the version as 3.4.

ssorgatem commented on 2018-03-20 17:33

@DrDoctor that means your version of wine-vulkan is below 3.4.

Either re-install wine-vulkan-git so that it gets the current code or install some other wine package that gives at least wine 3.4

WhatTheBuck commented on 2018-03-20 17:21

I can't install this without uninstalling wine-vulkan-git. It tries to install wine-staging instead.

ssorgatem commented on 2018-03-10 17:49

It looks like you don't have wine-vulkan properly setup

earthboundin commented on 2018-03-10 17:32

[ryan@Pepperanne Fallout 4]$ wine Fallout4.exe 000b:fixme:winediag:start_process Wine Staging 3.3 is a testing version containing experimental patches. 000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org. 002f:err:module:import_dll Library vulkan-1.dll (which is needed by L"C:\windows\system32\d3d11.dll") not found 002f:err:module:import_dll Library vulkan-1.dll (which is needed by L"C:\windows\system32\DXGI.DLL") not found 002f:err:module:import_dll Library DXGI.DLL (which is needed by L"C:\windows\system32\d3d11.dll") not found 002f:err:module:import_dll Library d3d11.dll (which is needed by L"J:\bigolboy\Games\Fallout 4\Fallout4.exe") not found 002f:err:module:import_dll Library vulkan-1.dll (which is needed by L"C:\windows\system32\dxgi.dll") not found 002f:err:module:import_dll Library dxgi.dll (which is needed by L"J:\bigolboy\Games\Fallout 4\Fallout4.exe") not found 002f:err:module:attach_dlls Importing dlls for L"J:\bigolboy\Games\Fallout 4\Fallout4.exe" failed, status c0000135 [ryan@Pepperanne Fallout 4]$

Getting this when I try to run Fallout 4. I ran the setup script, but to no avail.

ssorgatem commented on 2018-03-08 20:54

Thank you, I've updated the package.

frankyboy commented on 2018-03-08 18:59

version 0.31 is out https://github.com/doitsujin/dxvk/releases/tag/v0.31

ssorgatem commented on 2018-03-02 17:34

It looks like it's due to the archive having been packaged by bsdtar or a very old version of GNU tar: http://bugs.rosalinux.ru/show_bug.cgi?id=712

It shouldn't have any ill effect, though.

zfkerr commented on 2018-03-02 16:50

@ssorgatem, do you know what this means? This happens during the building.

Starting build()...

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x32/

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x32/d3d11.dll

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x32/setup_dxvk.sh

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x32/dxgi.dll

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x64/

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x64/d3d11.dll

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x64/setup_dxvk.sh

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/x64/dxgi.dll

tar: Ignoring unknown extended header keyword 'SCHILY.fflags' dxvk-0.30/README.txt

ssorgatem commented on 2018-03-02 16:42

Oh, thank you for spotting that! Should be fixed now.