Package Details: dxvk-win32-bin 0.93-1

Git Clone URL: https://aur.archlinux.org/dxvk-bin.git (read-only)
Package Base: dxvk-bin
Description: A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine (binary files)
Upstream URL: https://github.com/doitsujin/dxvk
Licenses: zlib/libpng
Conflicts: dxvk-bin<0.63-5, dxvk-git<0.63-5, dxvk-win32-git
Provides: dxvk, dxvk32
Replaces: dxvk-bin
Submitter: ssorgatem
Maintainer: ssorgatem
Last Packager: ssorgatem
Votes: 66
Popularity: 7.580258
First Submitted: 2018-03-02 07:39
Last Updated: 2018-11-25 00:21

Pinned Comments

ssorgatem commented on 2018-03-27 06:47

As of 0.60, wine >3.10 is needed.

To enable DXVK in a wineprefix, do the following (with the WINEPREFIX variable properly set):

For 32-bit D3D10/11: setup_dxvk32

For 64-bit D3D10/11: setup_dxvk64

In order to uninstall DXVK from a wineprefix, you can just disable the DLL overrides (set them to "builtin") through winecfg or winetricks.

Latest Comments

1 2 3 4 5 Next › Last »

ssorgatem commented on 2018-10-13 07:28

@BrianAllred it should be fixed now

BrianAllred commented on 2018-10-12 22:20

Is there anyway the script could have a proper shebang (#!/bin/sh) at the top? I use fish shell, and it can't execute the script (throws "Exec format error"), so I currently either have to run it in a bash shell, wrap it in a bash one-liner, or put the shebang in there myself.

Not a big deal, but would be nice to have. Thanks for maintaining this!

ssorgatem commented on 2018-09-30 00:22

It actually was updated, but it looks like it has changed again without notice or version change (it's no the first time it happens...)

linuxuser437442 commented on 2018-09-29 23:41

sha256sum in the makepkg for the dxvk-0.80.tar.gz seems to have not been updated from the last tar.gz file:

sha256sums=("f9e736cdbf1e83e45ca748652a94a3a189fc5accde1eac549b2ba5af8f7acacb" "1a88e01e02ef9bfd9bf43d8dec4e70b425fb25812f597463ee4145705c82a504")

7058a834bb006cad5462933110449b434df561e67d83f68d3965ecc74e2e1cbc dxvk-0.80.tar.gz

Thank you for the update!

ssorgatem commented on 2018-09-09 22:50

@sum01 mut be a problem on your end or a temporal githug issue, it works well for me.

sum01 commented on 2018-09-09 19:01

The upstream url is a dead link.

ssorgatem commented on 2018-08-28 04:34

@Greencopper, the "dxvk-bin" package contains nothing, it just depends on tje 32 and 64 bit packages.

greencopper commented on 2018-08-28 04:19

sudo pacman -U dxvk-bin-0.70-2-x86_64.pkg.tar.xz 
loading packages...
resolving dependencies...
warning: cannot resolve "dxvk-win32-bin", a dependency of "dxvk-bin"
warning: cannot resolve "dxvk-win64-bin", a dependency of "dxvk-bin"
:: The following package cannot be upgraded due to unresolvable dependencies:
      dxvk-bin

:: Do you want to skip the above package for this upgrade? [y/N]

zfkerr commented on 2018-08-17 15:36

Hi, @ssorgatem! DXVK 0.70 release brought the completely abolition of setup_dxvk.sh. Philip "Doitsujin" Rebohle, the DXVK author thinks that it's you who should write a new such script, or take its setup_dxvk.sh script and add it to all your DXVK PKGBUILS's. Can we hope that you will do this? More details of this discussion can be found here: https://github.com/doitsujin/dxvk/issues/572

Thank you! Regards!

TheRealSoup commented on 2018-08-17 14:18

In package_dxvk-win32-bin

Should it be replaces=("dxvk-bin") or replaces=("dxvk-bin<0.63-5")