Package Details: dynalist-desktop 1.0.5-2

Git Clone URL: https://aur.archlinux.org/dynalist-desktop.git (read-only, click to copy)
Package Base: dynalist-desktop
Description: Dynalist lets you organize your ideas and tasks in simple lists. It's powerful, yet easy to use.
Upstream URL: https://dynalist.io
Licenses: Private
Provides: dynalist
Submitter: bramswenson
Maintainer: jhrdka
Last Packager: jhrdka
Votes: 5
Popularity: 1.03
First Submitted: 2017-05-29 17:46
Last Updated: 2020-03-03 06:34

Dependencies (2)

Required by (0)

Sources (3)

Latest Comments

1 2 Next › Last »

E3LDDfrK commented on 2020-03-11 02:43

@jhrdka I understand. Then just do as you do it now. Thanks for the work.

jhrdka commented on 2020-03-07 20:36

There are two parts of the application: The webapp wrapper and the webapp itself. The wrapper (the tarball downloaded in this PKGBUILD) wasn't updated for several years and is labelled with version 1.0.5. This is the number I use because this is the number relevant for creating new versions of this package.

The webapp that runs inside the wrapper gets updated automatically, is saved in the user profile and is independent on the version of the runner. The current version is indeed 1.3.3, but when 1.3.4 comes up, there is no need to update this package with the webapp wrapper.

@E3LDDfrK Are you OK with my decision to use the version number from the downloaded tarball or would you prefer to use 1.3.3 even though there is in fact no code of Dynalist 1.3.3 in the package?

E3LDDfrK commented on 2020-03-03 13:16

@jhrdka The version of desktop dynalist is 1.3.3.

jhrdka commented on 2020-03-03 06:35

Symbolic link fixed. Thanks for reporting, sorry for the delay.

E3LDDfrK commented on 2020-01-10 18:11

I second @ViImproved. In the PKGBUILD, please replace

ln -sf "${pkgdir}/opt/dynalist/dynalist" "${pkgdir}/usr/bin/dynalist"

with

ln -sf "/opt/dynalist/dynalist" "${pkgdir}/usr/bin/dynalist"

In my case, the first line results in a broken link to "/home/username/.cache/pikaur/build/dynalist-desktop/pkg/dynalist-desktop/opt/dynalist/dynalist" in /usr/bin. I only have three other packages in /opt: spotify, minetime, and dropbox. Their symbolic links work fine.

erayerdin commented on 2019-08-08 21:02

@jhrdka, I also tested it out again and it is working. Very odd.

jhrdka commented on 2019-08-07 21:03

@erayerdin Interesting, I cannot reproduce your issue. I tested the compile/install process using yaourt on two computers and no problem. For me the sha512sum of the downloaded dynalist.tar.gz (https://dynalist.io/standalone/download?file=dynalist.tar.gz) (v1.0.5) starts with "d21340de15ad..." as stated in PKGBUILD.

erayerdin commented on 2019-08-02 21:31

"One or more files did not pass the validity check!"

ppsimha commented on 2018-11-14 14:50

@bramswenson, I'll maintain the package.

Wykedengel commented on 2018-08-26 14:55

I had success with installing this by first installing the gconf-3.2.6 package in the AUR. This also works if I download the file directly from the site, extract it and then open Dynalist from the folder.