Package Details: e-deklaracje 10.0.1-1

Git Clone URL: https://aur.archlinux.org/e-deklaracje.git (read-only)
Package Base: e-deklaracje
Description: Application for submitting tax return in Poland
Upstream URL: http://www.finanse.mf.gov.pl/systemy-informatyczne/e-deklaracje
Licenses: custom
Submitter: proxy
Maintainer: proxy (kszonek)
Last Packager: proxy
Votes: 14
Popularity: 0.840109
First Submitted: 2016-01-30 15:08
Last Updated: 2018-03-11 14:03

Dependencies (2)

Required by (0)

Sources (2)

Pinned Comments

proxy commented on 2017-01-17 20:47

There is an issue with acrobat reader which crashes after 15s... this of course impacts e-deklaracje too, see here: https://aur.archlinux.org/packages/acroread/

As a temporary solution: comment out the ipv6 line (::1) in /etc/hosts (this might impair your ipv6 connectivity and functionality of locally communicating programs)

Another solution is to pass env: export GTK2_RC_FILES="/usr/share/gtk-2.0/gtkrc", easiest to do is: cp /usr/share/applications/acroread.desktop ~/.local/share/applications/ and modify Exec to: Exec=env GTK2_RC_FILES="/usr/share/gtk-2.0/gtkrc" acroread %F

Latest Comments

revel commented on 2018-04-25 17:03

This app needs 'lib32-libxt' to successfully open pdf forms. It should be added as a dependency of this package or any of its current deps (acroread, adobe-air).

Faalagorn commented on 2018-04-20 13:56

Not sure how important it is, but both the url and source can be safely changed to https, as the https links seem to work fine (I modified my PKGBUILD like that before installing).

proxy commented on 2018-01-06 11:40

Good idea, thx!

MarcinWieczorek commented on 2018-01-06 11:09

I recommend changing the name of the source so it is easier to deal with shared source directories for AUR packages. http://sprunge.us/XERF?diff If anyone wants to join me on reverse engineering the protocol please contact me. This app is shitty as hell but we have to use it.

Cysioland commented on 2018-01-06 00:52

:: Sprawdzanie zależności e-deklaracje...

==> Tworzenie pakietu: e-deklaracje 10.0.0-1 (sob, 6 sty 2018, 01:46:39 CET)

==> Pobieranie źródeł...

-> Znaleziono e-DeklaracjeDesktop.air

-> Znaleziono e-deklaracje.desktop

==> Sprawdzanie plików source za pomocą sha256sums...

e-DeklaracjeDesktop.air ... NIE ZGADZA SIĘ

e-deklaracje.desktop ... Zgadza się

==> BŁĄD: Przynajmniej jeden plik nie jest poprawny!

karas77 commented on 2017-10-25 21:03

==> Tworzenie pakietu: e-deklaracje 9.0.5-1 (śro, 25 paź 2017, 22:45:02 CEST)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
-> Znaleziono e-DeklaracjeDesktop.air
-> Znaleziono e-deklaracje.desktop
==> Sprawdzanie plików source za pomocą sha256sums...
e-DeklaracjeDesktop.air ... NIE ZGADZA SIĘ
e-deklaracje.desktop ... Zgadza się
==> BŁĄD: Przynajmniej jeden plik nie jest poprawny!

MarcinWieczorek commented on 2017-06-26 14:01

Thank you for providing this package. I wanted to do that quite some time ago, I haven't thought so many people would use it. The package script is quite ok, there are a few flaws tho. First of all the pkgrel is not supposed to be '0'. md5 is deprecated, please use something stronger. I'd consider providing a run script in /usr/bin for easier debugging in case our government fucks it up again.

Here's a patch: http://sprunge.us/XhEP?diff

proxy commented on 2017-01-17 20:47

There is an issue with acrobat reader which crashes after 15s... this of course impacts e-deklaracje too, see here: https://aur.archlinux.org/packages/acroread/

As a temporary solution: comment out the ipv6 line (::1) in /etc/hosts (this might impair your ipv6 connectivity and functionality of locally communicating programs)

Another solution is to pass env: export GTK2_RC_FILES="/usr/share/gtk-2.0/gtkrc", easiest to do is: cp /usr/share/applications/acroread.desktop ~/.local/share/applications/ and modify Exec to: Exec=env GTK2_RC_FILES="/usr/share/gtk-2.0/gtkrc" acroread %F

Tomek80Bytom commented on 2016-10-21 16:30

If you have problem with md5sum for latest version of e-DeklaracjeDesktop.air please use 4cf63e0317f1bc5f165e957d9b7a6d4a insted of f97ad5c78f6d146d90ccab7cf3a7af64.

Best regards. :-)

kszonek commented on 2016-05-02 11:55

@niezniszczalny

It means you don't have those installed, but pacman is trying to install those as it is dependency of adobe-air-sdk. You don't have multilib repopositories enabled on your 64bit system, so uncomment multilib mirror in /etc/pacman.conf and it will work just fine.

niezniszczalny commented on 2016-05-02 11:38

:: resolving dependencies...
:: no results found for lib32-gcc-libs
:: no results found for lib32-gtk2
:: no results found for lib32-libxml2
:: no results found for lib32-libxslt
:: no results found for lib32-nss

As a newbie I'd like to ask - does it mean that I don't have these libraries installed? If yes, please add these dependencies to the package in the future.

inox commented on 2016-04-30 12:40

Działające e-Deklaracje na 64-bitowym Archu, wraz ze sprawnym Adobe Acrobat Reader (9.5.5-5), Adobe AIR (2.6-1) i wszystkimi 32-bitowymi zależnościami, których te wymagają. Tak w jednym zdaniu można określić paczkę Kszonka! POLECAM!

gonciarz commented on 2016-04-10 06:50

The package works perfectly. Thank you.
I sent an email to Polish Ministry of Finance with suggestion to officially support Arch Linux version.
Best regards
R.

kszonek commented on 2016-03-14 10:26

@firekage
There is also import/export in settings of e-Deklaracje.

proxy commented on 2016-03-14 09:53

@firekage ~/.appdata

firekage commented on 2016-03-13 21:19

Could somebody tell me where are being stored config for it? I sent declaration, would like to backup it.

pan-mroku commented on 2016-03-08 20:10

md5sum for version 8.0.7:
f97ad5c78f6d146d90ccab7cf3a7af64

proxy commented on 2016-02-09 18:12

Updated

jakub commented on 2016-02-07 10:59

md5sums check failed:

==> Sprawdzam pliki source za pomocą md5sums...
e-DeklaracjeDesktop.air ... NIE ZGADZA SIĘ
e-deklaracje.desktop ... Zgadza się
==> BŁĄD: Przynajmniej jeden plik nie jest poprawny!
==> BŁĄD:Makepkg nie był w stanie zbudować e-deklaracje.