Package Details: e2guardian 5.3.4-1

Git Clone URL: https://aur.archlinux.org/e2guardian.git (read-only, click to copy)
Package Base: e2guardian
Description: Fork of dansguardian, an open source web content filter. It filters the actual content of pages based on many methods including phrase matching, request header and URL filtering, etc. It does not purely filter based on a banned list of sites.
Upstream URL: http://e2guardian.org
Keywords: dansguardian filtering https proxy squid ssl url web
Licenses: GPL2
Conflicts: dansguardian, dansguardian-dev
Submitter: Prophecy
Maintainer: Prophecy
Last Packager: Prophecy
Votes: 6
Popularity: 0.001236
First Submitted: 2015-11-22 11:08 (UTC)
Last Updated: 2020-03-15 09:03 (UTC)

Latest Comments

senorsmile commented on 2022-06-20 22:22 (UTC)

I get the same errors as Kohane27. I tried building the last several releases to the AUR, all with the same results.

kohane27 commented on 2021-12-15 02:01 (UTC)

I'm having trouble building:

Preparing...
Cloning e2guardian build files...
Generating e2guardian information...
Checking e2guardian dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building e2guardian...
==> Making package: e2guardian 5.3.4-1 (Wednesday, December 15, 2021 AM09:59:57)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading v5.3.4.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   129  100   129    0     0    284      0 --:--:-- --:--:-- --:--:--   284

100 98392    0 98392    0     0  90427      0 --:--:--  0:00:01 --:--:-- 90427
100 2034k    0 2034k    0     0  1326k      0 --:--:--  0:00:01 --:--:-- 4355k
  -> Found e2guardian
  -> Found e2guardian.service
==> Validating source files with sha1sums...
    v5.3.4.tar.gz ... Passed
    e2guardian ... Passed
    e2guardian.service ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting v5.3.4.tar.gz with bsdtar
==> Starting build()...
+ cp README.md README
+ aclocal -I m4
configure.ac:12: error: AM_INIT_AUTOMAKE expanded multiple times
/usr/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:9: the top level
/usr/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:12: the top level
autom4te: error: /usr/bin/m4 failed with exit status: 1
aclocal: error: autom4te failed with exit status: 1
==> ERROR: A failure occurred in build().
    Aborting...

Any help is much appreciated.

kauron commented on 2020-05-10 11:18 (UTC) (edited on 2020-05-10 11:19 (UTC) by kauron)

The file /etc/logrotate.d/e2guardian should be patched to change from service to systemctl; otherwise there are errors when running logrotate.

amiad commented on 2019-07-17 12:28 (UTC)

You should add the flag --enable-sslmitm=yes to the compile for MITM Filtering. https://github.com/e2guardian/e2guardian/wiki/MITM---Filtering-HTTPS

macxcool commented on 2017-04-27 20:42 (UTC) (edited on 2017-04-27 20:44 (UTC) by macxcool)

file conflicts: /var/run exists in filesystem ;-) I guess so! The package seems to have the /var/run folder in it. There are no files inside that folder, just the folder.

zapataz commented on 2017-02-28 16:36 (UTC)

E2guardian can be compiled for armv7h by adding this architecture in PKGBUILD arch line arch=('i686' 'x86_64' 'armv6h' 'arm')

Prophecy commented on 2015-11-22 11:35 (UTC)

Maybe it's useful for somebody. You can change the running user/group in the config files. I was not able to get clamd working with e2guardian, always permission errors for reading/writing of temp dirs. General contentfiltering with squid works.