Package Details: easy-installer 0.20.1-1

Git Clone URL: https://aur.archlinux.org/easy-installer.git (read-only, click to copy)
Package Base: easy-installer
Description: The Easy Installer is a desktop application which helps users install Android /e/ (https://doc.e.foundation/what-s-e) on supported devices.
Upstream URL: https://gitlab.e.foundation/e/tools/easy-installer
Keywords: android
Licenses: GPL3
Submitter: steadfasterX
Maintainer: efoundation (steadfasterX)
Last Packager: efoundation
Votes: 5
Popularity: 0.026130
First Submitted: 2020-12-23 14:03 (UTC)
Last Updated: 2024-03-06 08:08 (UTC)

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

xiota commented on 2024-03-26 10:57 (UTC)

Package needs to be revised to install to standard locations, not /usr/local.

Tio commented on 2023-11-16 02:07 (UTC)

Please add the icon path as relative not Icon=/opt/easy-installer/easy-installer.png . So: Icon=easy-installer . I am making custom icons for the Zafiro Icon package and we cannot theme any icon if the .desktop file points to a specific directory. Thanks!

steadfasterX commented on 2023-07-05 09:05 (UTC)

@kozaki: could you pls try to replace this line in PKGBUILD

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=easy-installer#n57

ronn -r --pipe ../${MAN8PAGE}.md > $pkgdir/${MAN8DIR}/${MAN8PAGE}

with:

ronn -r --pipe $srcdir/${MAN8PAGE}.md > $pkgdir/${MAN8DIR}/${MAN8PAGE}

kozaki commented on 2022-12-28 19:06 (UTC)

Hi, thx for making this PKGBUILD :) Am unable to build; 'package()' fails at the ruby-ronn-ng step:

==> Entering fakeroot environment...
==> Starting package()...
/usr/lib/ruby/gems/3.0.0/gems/ronn-ng-0.9.1/lib/ronn/document.rb:79:in `read': No such file or directory @ rb_sysopen - ../easy-installer.8.md (Errno::ENOENT)

steadfasterX commented on 2022-08-24 10:31 (UTC)

@beiju: until this gets updated here, do this:

https://gitlab.e.foundation/e/devices/easy-installer/-/merge_requests/167/diffs?commit_id=1fa1338084caf2d063bf8aae45a9b3c3a9f7555b

beiju commented on 2022-08-20 20:01 (UTC)

Not able to build: * What went wrong: Execution failed for task ':jlink'.

Process 'command '/usr/lib/jvm/java-11-openjdk/bin/jlink'' finished with non-zero exit value 1