Package Details: easyconnect 7.6.7.3.76b7ebc57725ae1e999151cdc215f8e7cef8a31b-1

Git Clone URL: https://aur.archlinux.org/easyconnect.git (read-only, click to copy)
Package Base: easyconnect
Description: Support access to ssl vpn. With easyconect,you can secure and speed up connection to cooperate network at ease!
Upstream URL: http://www.sangfor.com.cn
Licenses: custom
Submitter: attenuation
Maintainer: None
Last Packager: arthur_0
Votes: 6
Popularity: 0.000208
First Submitted: 2018-07-28 12:09
Last Updated: 2020-03-13 08:15

Pinned Comments

arthur_0 commented on 2020-02-17 02:47

关于"您的客户端版本与服务器不匹配,请更新"的问题:

easyconnect服务器端会要求与客户端版本一致,因此,如果遇到版本过低或不一致情况,需手动修改PKGBUILD到你要连接的服务器端版本。

Latest Comments

1 2 3 4 Next › Last »

zydxhs commented on 2021-10-25 11:58

登录问题解决,原来必须以 root 权限执行 sslservice.sh: sudo /usr/share/sangfor/EasyConnect/resources/shell/sslservice.sh

zydxhs commented on 2021-10-18 13:47

遇到个奇怪的问题:弹出登录成功的对话框后,EasyConnect的图标一直在闪,不会变绿。

zydxhs commented on 2021-10-18 13:45

关于无法保存帐号、URL,@komerebi 说的不完全正确。 我测试了下,配置文件的名字应该 easy_connect.json,其它没有问题。

sudo chmod 777 /usr/share/sangfor/EasyConnect/resources/conf

或者(xxx表示你的用户名和组名)

sudo touch /usr/share/sangfor/EasyConnect/resources/conf/easy_connect.json
sudo chown xxx:xxx /usr/share/sangfor/EasyConnect/resources/conf/easy_connect.json

komerebi commented on 2021-08-10 10:05

@plutonem 无法保存密码是因为配置文件夹权限的问题。 可以粗暴一点直接把“/usr/share/sangfor/EasyConnect/resources/conf”这个文件直接设置为777的权限。或者在这个文件夹下新建一个 setting_你的用户名.json 文件,设置为你的用户可读写。应该就能保存信息了

plutonem commented on 2021-05-15 06:32

原来的deb版在ubuntu上是会自动保存服务器的url的,不需要每次启动手动输入一次,但这个在arch上不行,不知道是哪个库的缘故。

palytoxin commented on 2021-03-02 00:30

根据指定评论修改了PKGBUILD到你要连接的服务器端版本。可以正常安装感谢。 我目前安装的版本是7.6.3.0.86415 登录会有闪退的问题。需要在登录进度过半后执行

sudo /usr/share/sangfor/EasyConnect/resources/shell/sslservice.sh 即可完成登录

peeeee commented on 2020-11-18 01:52

系统更新后,可以连接,但无法打开网页。参照https://www.wannaexpresso.com/2020/06/07/easy-connect-manjaro/ 重新安装后,可以正常访问。

holly commented on 2020-06-13 05:05

7_6_7_3运行的时候出现 (EasyConnect:8913): Pango-ERROR **: 10:41:49.509: Harfbuzz version too old (1.3.1) 错误

尝试了安装的时候不安装pango-1.42.4.tar.xz,直接安装EasyConnect_x64_7_6_7_3.deb之后,找到一些老的lib 复制到/usr/share/sangfor/EasyConnect,可以成功运行。

holly  …  share  sangfor  EasyConnect  pwd /usr/share/sangfor/EasyConnect  holly  …  share  sangfor  EasyConnect  tree -L 1 . ├── blink_image_resources_200_percent.pak ├── content_resources_200_percent.pak ├── content_shell.pak ├── EasyConnect ├── girepository-1.0 ├── icudtl.dat ├── libffmpeg.so ├── libgconf-2.so.4 ├── libharfbuzz-icu.so.0 ├── libharfbuzz-icu.so.0.10800.7 ├── libharfbuzz.so.0 ├── libharfbuzz.so.0.10800.7 ├── libharfbuzz-subset.so.0 ├── libharfbuzz-subset.so.0.10800.7 ├── libnode.so ├── libpango-1.0.so.0 ├── libpango-1.0.so.0.4200.3 ├── libpangocairo-1.0.so.0 ├── libpangocairo-1.0.so.0.4200.3 ├── libpangoft2-1.0.so.0 ├── libpangoft2-1.0.so.0.4200.3 ├── libpangoxft-1.0.so.0 ├── libpangoxft-1.0.so.0.4200.3 ├── libXss.so.1 ├── LICENSE ├── LICENSES.chromium.html ├── locales ├── natives_blob.bin ├── pdf_viewer_resources.pak ├── resources ├── snapshot_blob.bin ├── ui_resources_200_percent.pak ├── version └── views_resources_200_percent.pak

3 directories, 31 files

这些lib有一个网盘连接 https://pan.baidu.com/s/1PsQqbFNKj0kJIeJjiEZPNw 密码1234

不过web访问还是弹不出来客户端,直接从客户端访问可以成功

Hagb commented on 2020-05-13 10:13

另外虽然 EasyConnect 的 deb 包信息中写 License 是 custom ,但是包里的/usr/share/sangfor/EasyConnect/LICENSE却是一份 MIT 协议。

研究了下,EasyConnect 客户端前端的源代码居然可在/usr/share/sangfor/EasyConnect/resources/app.asar找到,里面的 js 代码是未经混淆的,经过格式化后是可以看的。

由此看来还有重制一个前端以及纯 CLI 使用 EasyConnect 的可能。(但这就需要有大佬去搞这个事情了)

Hagb commented on 2020-05-13 10:04

最近把 EasyConect 的 deb 版本弄进了 docker 里面 https://github.com/Hagb/docker-easyconnect ,其中容器开放 socks5 以供宿主机访问 vpn。

记录了一下其中遇到过的坑,应该也适用于非容器化的情形(it should work, 但未测试,欢迎测试过的朋友 PR):https://github.com/Hagb/docker-easyconnect/blob/master/doc/run-linux-easyconnect-how-to.md

希望能起到一些微薄的作用。

2020 年 5 月 14 日 Update: 好像我这里折腾的是 7.6.3.0.86415 旧版,因为学校用的是旧版,新版没有折腾的条件,所以也没办法在新版上验证了(听说其中一些问题已经在新版客户端里面修复了)