Package Details: easyeda-bin 6.5.40-1

Git Clone URL: https://aur.archlinux.org/easyeda-bin.git (read-only, click to copy)
Package Base: easyeda-bin
Description: A Simple and Powerful Electronic Circuit Design Tool
Upstream URL: https://easyeda.com/
Keywords: easyeda eda pcb
Licenses: LicenseRef-EasyEDA-Proprietary
Conflicts: easyeda
Provides: easyeda
Submitter: v.prokopyev
Maintainer: v.prokopyev (Misaka13514)
Last Packager: Misaka13514
Votes: 8
Popularity: 0.94
First Submitted: 2020-10-20 20:53 (UTC)
Last Updated: 2024-02-20 12:16 (UTC)

Pinned Comments

Misaka13514 commented on 2022-08-12 11:04 (UTC) (edited on 2022-08-12 11:22 (UTC) by Misaka13514)

See also:

Latest Comments

1 2 Next › Last »

Misaka13514 commented on 2022-10-24 09:10 (UTC)

@rcolistete Thanks for the report. I can't reproduce that now. (Maybe the CDN closest to my network caches for a long time since the URL isn't changed?) I will try again in the next few days.

Btw, you can also use makepkg --skipchecksums.

rcolistete commented on 2022-10-24 05:56 (UTC)

I had to change line 18 with new sha256 : sha256sums=('a277dc4ce102d433f37b4ff3244d11212c948d9606e1c81379a073a00f8ee2d9'

dev31 commented on 2022-10-20 08:17 (UTC)

@Misaka13514 It's fine now, thank you!

Misaka13514 commented on 2022-10-20 01:25 (UTC) (edited on 2022-10-20 01:28 (UTC) by Misaka13514)

@bakgwailo Thank you. I also reproduced that just now. Fixed in 6.5.20-2.

bakgwailo commented on 2022-10-20 01:22 (UTC)

yeah, new sha256 is:

b81925747b3d8024f1c86ea2bbaacf634f013fe5f16a956d922845f4776dd9c4

Misaka13514 commented on 2022-10-19 00:12 (UTC) (edited on 2022-10-19 00:20 (UTC) by Misaka13514)

@dev31 Thank you for your report. I cleared my local cache and tried to makepkg again at Wed 19 Oct 2022 00:03:48 AM UTC, I didn't get a validation failed error, the package built successfully, so I can't reproduce that. Can you try again and tell me the result? Thanks.

Upstream sometimes re-releases a version in place, so I sometimes don't notice that the package changes.

dev31 commented on 2022-10-18 16:19 (UTC) (edited on 2022-10-18 16:19 (UTC) by dev31)

@Misaka13514 Seems like updating and installing is not working:

Building easyeda-bin...
==> Making package: easyeda-bin 6.5.20-1 (Thuesday, 18-Oct-2022 19:16:31 +0300)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found easyeda-6.5.20.zip
  -> Found LICENSE
==> Validating source files with sha256sums...
    easyeda-6.5.20.zip ... FAILED
    LICENSE ... Passed
==> ERROR: One or more files did not pass the validity check!
Failed to build easyeda-bin

Misaka13514 commented on 2022-08-12 11:04 (UTC) (edited on 2022-08-12 11:22 (UTC) by Misaka13514)

See also:

dev31 commented on 2022-07-20 18:58 (UTC)

Perfect! Thank you @Misaka13514! Updating and installing both are working well now!