Package Details: easyeffects-git 6.1.4.r32.gf76cf2be-1

Git Clone URL: https://aur.archlinux.org/easyeffects-git.git (read-only, click to copy)
Package Base: easyeffects-git
Description: Audio Effects for Pipewire applications
Upstream URL: https://github.com/wwmm/easyeffects
Licenses: GPL3
Conflicts: easyeffects
Provides: easyeffects
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 11
Popularity: 1.46
First Submitted: 2021-06-26 11:51
Last Updated: 2021-11-01 00:22

Required by (1)

Sources (1)

Latest Comments

1 2 3 Next › Last »

maxpayne3 commented on 2021-10-31 09:46

New tbb dependency has been added. See changelog.

Please update according to the master PKGBUILD

almet commented on 2021-10-10 13:56

I haven't been able to install this on my system. It says "libpipewire-0.3" is missing (but it's not packaged it seems, and I have pipewire-0.3 installed already).

I also had to install nlohmann-json-git manually (via yay nlohmann-json-git).

Any idea how to solve this? :-)

AlexWayfer commented on 2021-09-29 19:08

https://github.com/wwmm/easyeffects/issues/1163#issuecomment-930399655

Could you please add additional flags for debugging?

hashworks commented on 2021-07-07 12:08

You might want to add replaces and provides for pulseeffects-git.

shaybox commented on 2021-06-14 20:21

This requires boost-libs 1.7.5, current version is 1.7.6 and it fails to open.

RX14 commented on 2021-02-10 21:28

This package should depend on gst-plugin-pipewire.

robertfoster commented on 2021-02-10 20:48

@Saancreed @yochananmarqos refers initially to makedepends override for splitted packages. Now I got it. Will upload an updated one asap

Saancreed commented on 2021-02-10 15:46

Hello @robertfoster,

@yochananmarqos is mostly right, your PKGBUILD needs to also declare build dependencies of each split package at the top level, otherwise what you assign to depends in each package function is expected to be a runtime–only dependency, not something required during the build. Obviously, building PulseEffects without PipeWire already installed is doomed to fail and building plugins without rnnoise available at build time will disable integration with this plugin even if manually installed later. pacman rightfully doesn't install such dependencies unless they are in top level depends or makedepends (and so, visible immediately after the PKGBUILD is sourced), so the only way to currently build this package is in an environment where all dependencies luckily happen to already be installed manually, defeating the entire purpose of makedepends.

yochananmarqos commented on 2021-01-23 23:53

@robertfoster: I didn't say makedepends() was overridable, I was referring to depends(). Sorry I didn't make that clear.

robertfoster commented on 2021-01-23 22:50

@yochananmarqos It is the third time that our paths cross and it is the third time that you say things with extreme conviction and wrong.

Read the file in /usr/share/pacman/PKGBUILD-split.proto.

You will notice that makedepends is not overridable in subpackages and its also reasonable. What's the point of having different makedepends in subpackages if they both belong to the same codebase?

Let me also give you some advice: take the time to read what a person writes (code, documentation ...) and above all have the benefit of the doubt.

Regards