Package Details: easytag-opensuse-ogg-patch 2.4.3-9

Git Clone URL: https://aur.archlinux.org/easytag-opensuse-ogg-patch.git (read-only, click to copy)
Package Base: easytag-opensuse-ogg-patch
Description: Simple application for viewing and editing tags in audio files, using OpenSUSE patch
Upstream URL: https://wiki.gnome.org/Apps/EasyTAG
Licenses: GPL2
Conflicts: easytag
Provides: easytag
Submitter: yrlf
Maintainer: yrlf
Last Packager: yrlf
Votes: 2
Popularity: 0.098896
First Submitted: 2020-06-30 15:40 (UTC)
Last Updated: 2024-01-30 20:21 (UTC)

Required by (1)

Sources (3)

Latest Comments

1 2 Next › Last »

yrlf commented on 2024-01-30 13:59 (UTC)

@dreieck: ahh, yeah, I think I forgot to adjust the fix to check() I copied from the repo package. The ${pkgname} in the touch command should be ${_pkgname}.

dreieck commented on 2024-01-30 12:43 (UTC) (edited on 2024-01-30 12:46 (UTC) by dreieck)

your installed version of taglib is out of date. The Arch Linux package repos have updated to taglib 2.0 recently.

I now updated, and I get the following error in check():

==> Starting check()...
[...]
make[2]: Entering directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
  ITMRG  data/easytag.appdata.xml
  GEN      data/easytag.appdata.valid
data/easytag.appdata.xml: FAILED:
• tag-missing           : <content_rating> required [use https://odrs.gnome.org/oars]
• tag-missing           : <release> required
Validation of files failed
make[2]: *** [Makefile:4300: data/easytag.appdata.valid] Error 1
make[2]: Target 'check-am' not remade because of errors.
make[2]: Leaving directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
make[1]: *** [Makefile:3365: check-recursive] Error 1
make[1]: Leaving directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
make: *** [Makefile:3891: check] Error 2
==> ERROR: A failure occurred in check().

Regards,
P.S.:

If you are on Manjaro

I am on Artix.

yrlf commented on 2024-01-30 09:32 (UTC)

@dreieck: your installed version of taglib is out of date. The Arch Linux package repos have updated to taglib 2.0 recently.

If you are on Manjaro, you can either remove the 0001-taglib-2.patch from the PKGBUILD or just use git checkout HEAD~2 to switch to the previous version of the PKGBUILD.

dreieck commented on 2024-01-30 09:21 (UTC)

Build fails for me with gio_wrapper.h:38:58: error: ‘TagLib::offset_t’ has not been declared ans subsequent errors:

[...]
make[2]: Entering directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
  CC       src/easytag-cddb_dialog.o
  GEN      src/enums.c
  CC       src/easytag-enums.o
  CC       src/easytag-preferences_dialog.o
  CC       src/easytag-scan_dialog.o
  CXX      src/tags/easytag-gio_wrapper.o
In file included from src/tags/gio_wrapper.cc:24:
src/tags/gio_wrapper.h:38:58: error: ‘TagLib::offset_t’ has not been declared
   38 |     virtual void insert (TagLib::ByteVector const &data, TagLib::offset_t start = 0, size_t replace = 0);
      |                                                          ^~~~~~
src/tags/gio_wrapper.h:39:31: error: ‘TagLib::offset_t’ has not been declared
   39 |     virtual void removeBlock (TagLib::offset_t start = 0, size_t length = 0);
      |                               ^~~~~~
src/tags/gio_wrapper.h:66:58: error: ‘TagLib::offset_t’ has not been declared
   66 |     virtual void insert (TagLib::ByteVector const &data, TagLib::offset_t start = 0, size_t replace = 0);
      |                                                          ^~~~~~
src/tags/gio_wrapper.h:67:31: error: ‘TagLib::offset_t’ has not been declared
   67 |     virtual void removeBlock (TagLib::offset_t start = 0, size_t len = 0);
      |                               ^~~~~~
src/tags/gio_wrapper.cc:73:26: error: ‘TagLib::offset_t’ has not been declared
   73 |                          TagLib::offset_t start,
      |                          ^~~~~~
src/tags/gio_wrapper.cc:80:1: error: variable or field ‘removeBlock’ declared void
   80 | GIO_InputStream::removeBlock (TagLib::offset_t start, size_t len)
      | ^~~~~~~~~~~~~~~
src/tags/gio_wrapper.cc:80:39: error: ‘offset_t’ is not a member of ‘TagLib’
   80 | GIO_InputStream::removeBlock (TagLib::offset_t start, size_t len)
      |                                       ^~~~~~~~
src/tags/gio_wrapper.cc:80:62: error: expected primary-expression before ‘len’
   80 | GIO_InputStream::removeBlock (TagLib::offset_t start, size_t len)
      |                                                              ^~~
src/tags/gio_wrapper.cc:242:23: error: ‘TagLib::offset_t’ has not been declared
  242 |                       TagLib::offset_t start,
      |                       ^~~~~~
In file included from /usr/lib/glib-2.0/include/glibconfig.h:9,
                 from /usr/include/glib-2.0/glib/gtypes.h:34,
                 from /usr/include/glib-2.0/glib/galloca.h:34,
                 from /usr/include/glib-2.0/glib.h:32,
                 from /usr/include/glib-2.0/gobject/gbinding.h:30,
                 from /usr/include/glib-2.0/glib-object.h:24,
                 from /usr/include/glib-2.0/gio/gioenums.h:30,
                 from /usr/include/glib-2.0/gio/giotypes.h:30,
                 from /usr/include/glib-2.0/gio/gio.h:28,
                 from src/tags/gio_wrapper.h:28:
src/tags/gio_wrapper.cc: In member function ‘virtual void GIO_IOStream::insert(const TagLib::ByteVector&, int, size_t)’:
/usr/include/glib-2.0/glib/gmacros.h:935:26: warning: comparison of integer expressions of different signedness: ‘long unsigned int’ and ‘int’ [-Wsign-compare]
  935 | #define MIN(a, b)  (((a) < (b)) ? (a) : (b))
      |                      ~~~~^~~~~
src/tags/gio_wrapper.cc:281:37: note: in expansion of macro ‘MIN’
  281 |                                     MIN (G_N_ELEMENTS (buffer), start),
      |                                     ^~~
src/tags/gio_wrapper.cc: At global scope:
src/tags/gio_wrapper.cc:354:1: error: variable or field ‘removeBlock’ declared void
  354 | GIO_IOStream::removeBlock (TagLib::offset_t start, size_t len)
      | ^~~~~~~~~~~~
src/tags/gio_wrapper.cc:354:36: error: ‘offset_t’ is not a member of ‘TagLib’
  354 | GIO_IOStream::removeBlock (TagLib::offset_t start, size_t len)
      |                                    ^~~~~~~~
src/tags/gio_wrapper.cc:354:59: error: expected primary-expression before ‘len’
  354 | GIO_IOStream::removeBlock (TagLib::offset_t start, size_t len)
      |                                                           ^~~
make[2]: *** [Makefile:3022: src/tags/easytag-gio_wrapper.o] Error 1
make[2]: Leaving directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
make[1]: *** [Makefile:3365: all-recursive] Error 1
make[1]: Leaving directory '/tmp/makepkg/build/easytag-opensuse-ogg-patch/src/easytag-2.4.3'
make: *** [Makefile:1441: all] Error 2

(installed taglib version is 1.13.1.)

Regards!

yrlf commented on 2024-01-29 23:01 (UTC)

I have done basic testing and read up on the GNOME GitLab issue. It seems the revert from OpenSUSE does not 100% fix the ogg issue, and there is an open MR that should make things better, but the project is apparently un(der)maintained, and nobody will merge it.

The OGG patch in this AUR package still seems fine for all the OGG files I have lying around (random sample checking, and none of them were corrupted), but maybe I will incorporate the fix from the MR at some point.

Issue: https://gitlab.gnome.org/GNOME/easytag/-/issues/8 MR: https://gitlab.gnome.org/GNOME/easytag/-/merge_requests/8

yrlf commented on 2024-01-29 22:42 (UTC)

Updated the package to more closely resemble the repo package. I have removed the lines disabling ogg vorbis support, since AFAIK the OpenSUSE patch works around this exact issue.

The package now builds again, though I don't have time to test it extensively right now. You may want to back up ogg files before trying this out, but it might just work.

yrlf commented on 2023-12-04 00:24 (UTC)

@dreieck: done!

dreieck commented on 2023-11-26 15:06 (UTC)

Ahoj,

thanks for your package.

Can you change provides=(easytag) to provides=("easytag=${pkgver}"), please?

Regards!

SpotlightKid commented on 2023-04-30 16:47 (UTC) (edited on 2023-04-30 16:56 (UTC) by SpotlightKid)

@ianux @shtrom: a workaround is inserting a line in in the PKGBUILD, which patches the Makefile to make the check of the appstream file more relaxed, which lets it pass:

diff --git a/PKGBUILD b/PKGBUILD
index b6370ea..7971ce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,6 +40,7 @@ build() {

 check() {
   cd "${srcdir}/${_pkgname}-${pkgver}"
+  sed -i -e 's/--nonet validate/--nonet validate-relax/' Makefile
   make -k check
 }

Alternatively, the approach from the package in the Extra repo works too:

https://github.com/archlinux/svntogit-packages/blob/packages/easytag/trunk/PKGBUILD#L46

shtrom commented on 2023-02-22 13:50 (UTC)

@ianux: same issue here. It seems to happen after the build, during the check phase. Commenting out the make check in the PKGBUILD allowed the package build to complete (albeit untested).