Package Details: eclim-git 2.4.1.r8.gcc3816e-1

Git Clone URL: https://aur.archlinux.org/eclim-git.git (read-only)
Package Base: eclim-git
Description: Provides the ability to integrate Eclipse code editing features into your favorite editor
Upstream URL: http://eclim.org/
Licenses: GPL3
Conflicts: eclim
Submitter: Citral
Maintainer: galaux
Last Packager: galaux
Votes: 15
Popularity: 0.000568
First Submitted: 2009-12-24 13:07
Last Updated: 2015-07-04 13:57

Dependencies (10)

Required by (0)

Sources (2)

Latest Comments

euclio commented on 2015-08-16 07:21

Patch to build with the latest eclipse: https://gist.github.com/euclio/ddb0da9ae95d4cb3084b

euclio commented on 2015-05-26 23:11

stupidix: Building the docs is broken until https://github.com/ervandew/eclim/pull/401 is merged. You can get remove those lines from the PKGBUILD to finish the build.

Something is wrong with the build process for eclim and eclipse-scala-ide. I was able to get a local build/install to work, but makepkg fails. Perhaps someone more familiar with the code has diagnose the issue?

stupidix commented on 2015-05-16 06:53

Hi! I can't get it to install, any ideas? Thx

gant:
[echo] ${eclipse}: /usr/share/eclipse
[echo] ${eclipse.local}: /home/crichton/.eclipse/org.eclipse.platform_4.4.2_1543616141_linux_gtk_x86_64
[echo] ${eclipse.dest}: /tmp/packerbuild-1000/eclim-git/eclim-git/src/build
[echo] # Skipping org.eclim.wst, missing org.eclipse.wst.web_ui.feature
[echo] # Skipping org.eclim.sdt, missing org.scala-ide.sdt.feature
[echo] # Skipping org.eclim.pydev, missing org.python.pydev.feature
[echo] # Skipping org.eclim.pdt, missing org.eclipse.php
[echo] # Skipping org.eclim.groovy, missing org.codehaus.groovy.jdt.patch
[echo] # Skipping org.eclim.dltkruby, missing org.eclipse.dltk.ruby
[echo] # Skipping org.eclim.dltk, missing org.eclipse.dltk.core
[echo] # Skipping org.eclim.cdt, missing org.eclipse.cdt
[echo] # Skipping org.eclim.adt, missing com.android.ide.eclipse.adt.feature
[echo] Plugins:
[echo] org.eclim.jdt
docs:
init:
[echo] eclim.version: 2.4.1.3-ge91dcb4
[echo] eclim.release: 2.4.1
[echo] eclim.release.indigo: none
org.eclim.jdt.classpath:
------ org.eclim.jdt.classpath
------ init
[mkdir] Created dir: /tmp/packerbuild-1000/eclim-git/eclim-git/src/eclim-git/build/doc/site
[exec] Running Sphinx v1.3.1
[exec]
[exec] Extension error:
[exec] Could not import extension eclim.sphinx.rss (exception: cannot import name b)

meteor commented on 2015-02-19 15:34

Hi. Thanks for the convenient systemd user service script...
But according to https://bbs.archlinux.org/viewtopic.php?id=167142
you will need xvfb to run from systemd.
Maybe Add it to the dependencies?

meteor commented on 2015-02-19 15:34

Hi. Thanks for the convenient systemd user service script...
But According to https://bbs.archlinux.org/viewtopic.php?id=167142
you will need xvfb to run from systemd.
Maybe Add it to the dependencies?

galaux commented on 2014-12-25 17:51

Had not seen your last comment. Ok thanks, I have uploaded the version I mentioned. Not sure I will keep on using Eclim either but we'll see.

galaux commented on 2014-12-24 14:01

Wou!! Event better: I managed to add a Systemd User Service so now one can start eclimd with just

systemctl --user start eclimd

(Be sure however that Systemd has reloaded its list of daemons: `systemctl --user daemon-reload` – watch out for the `--user` and do not use sudo not root account!!)

AlexJF commented on 2014-12-24 13:40

I'll do you one better. Since I no longer use eclim anyway I'm disowning the package. Feel free to take ownership.

galaux commented on 2014-12-24 13:13

Hi. I could not get this package to build so I started over from AUR package 'eclim' and turned it into a brand new 'eclim-git'. Sources are available here [0]. Eclim 'git' works ok even though it does not work with Scala IDE but I plan to get a look at it.

Would you mind considering using these sources for this package? Thanks.

[0] https://github.com/galaux/arch_eclim-git

euclio commented on 2014-12-10 19:46

UPDATE: Here's a fix: add `mkdir -p $pkgdir/usr/share/eclipse` before the ant invocation in package(). Now eclim builds successfully again!

All comments