Package Details: eclipse-emf 2.12.0-1

Git Clone URL: https://aur.archlinux.org/eclipse-emf.git (read-only)
Package Base: eclipse-emf
Description: EMF and XSD frameworks for the Eclipse platform
Upstream URL: http://www.eclipse.org/modeling/emf/
Licenses: EPL
Submitter: xyproto
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 277
Popularity: 0.274850
First Submitted: 2011-12-14 17:01
Last Updated: 2016-06-30 13:45

Latest Comments

dsboger commented on 2015-07-23 02:42

It seems the problem is solved by following the Eclipse plugin package guidelines [1] and installing files under /use/lib/eclipse/dropins/emf/eclipse instead of the eclipse root /usr/lib/eclipse

[1] https://wiki.archlinux.org/index.php/Eclipse_plugin_package_guidelines

snack commented on 2015-07-22 08:00

It seems that this package is now (at least partially) included in eclipse-common:

error: failed to commit transaction (conflicting files)
eclipse-emf: /usr/lib/eclipse/features/org.eclipse.emf.common_2.11.0.v20150512-0501/META-INF/ECLIPSE_.RSA exists in filesystem

$ pacman -Qo /usr/lib/eclipse/features/org.eclipse.emf.common_2.11.0.v20150512-0501/META-INF/ECLIPSE_.RSA
/usr/lib/eclipse/features/org.eclipse.emf.common_2.11.0.v20150512-0501/META-INF/ECLIPSE_.RSA is owned by eclipse-common 4.5.0-3

darose commented on 2015-07-21 14:35

No longer working since yesterday's update to Eclipse Mars. Looks like /usr/share/eclipse needs to be updated to /usr/lib/eclipse in the PKGBUILD.

arthurzam commented on 2014-08-15 18:35

@vheuken
thank you - fixed

vheuken commented on 2014-08-15 10:05

This is broken. The URLs for the sources don't work anymore.

Here are the new, functioning URLs:

http://mirror.cc.columbia.edu/pub/software/eclipse/modeling/emf/emf/downloads/drops/2.10.0/R201405190339/emf-runtime-2.10.0.zip

http://mirrors.ibiblio.org/pub/mirrors/eclipse/modeling/emf/emf/downloads/drops/2.10.0/R201405190339/xsd-runtime-2.10.0.zip

arthurzam commented on 2014-07-05 17:47

@Shanto
thank you very much.
I updated it after testing the new version (as was suggested also in the comments)

Shanto commented on 2014-07-05 17:39

@arthurzam disowned.

s4ndman commented on 2014-06-30 18:36

pkgver=2.10.0
_reldate=201405190339

md5sums=('1391eb3d39e07dc2e5e3b48170341e6a'
'5d8052f72116a1f0f655c07438cf02d2')

zeppelinlg commented on 2014-03-06 13:49

_reldate=201402031126

Adlai commented on 2014-02-12 13:43

There's an update of 2.9.2 from 2014-02-03:

pkgver=2.9.2
pkgrel=2
_reldate=2014020031126
md5sums=('498713f53a20d7456042beaa3785baa4'
'1262af8447cb193807cd11c8849b5361')

ryuzy commented on 2014-01-20 15:50

@defkeh thanks for the update

defkeh commented on 2013-12-31 15:20

New version 2.9.2 released 2013-12-12

Update PKGBUILD to reflect

pkgver=2.9.2
_reldate=201312120558
md5sums=('49ad4a5d5f5f6c398307670308934915'
'749d11cfad706cef11901110b8ae66fe')

zeppelinlg commented on 2013-12-13 16:48

PKGBUILD for 2.9.1 with @Lekensteyn indications :
http://pastebin.com/fwYkhyH2

snack commented on 2013-11-10 10:26

@Lekensteyn My bad, sorry for the false alarm.

Lekensteyn commented on 2013-11-09 23:46

@snack https://projects.eclipse.org/projects/modeling.emf.emf/releases/2.10.0 says
"Release Date: Wednesday, June 25, 2014".

The latest is 2.9.1 according to http://www.eclipse.org/modeling/emf/downloads/?project=emf. This project has really bad release information, the news is outdated and information about versions is scattered.

I am now installing:
pkgver=2.9.1
_reldate=201309020605
md5sums=('806dc1b76296711535fcdbeb85ce6075'
'b6be5c0608d23256c082392ceab535e8')

Name Old Version New Version Net Change
eclipse-emf 2.8.1-2 2.9.1-1 -11.16 MiB

snack commented on 2013-10-04 08:17

2.10 is out:

http://cdnmi.mirror.garr.it/mirrors/eclipse/modeling/emf/emf/downloads/drops/2.10.0/

dront78 commented on 2013-08-24 06:08

I can confirm eclipse 4.3 fixes the problem with Android tools loading, but to get things working propery I deleted ~/.eclipse and ~/workspace/.metadata folders and setup Eclipse from scratch, overvise I got a lot Null pointer exceptions

snack commented on 2013-08-01 05:54

After upgrading to the new Eclipse 4.3 Kepler, eclipse-emf 2.9 stopped to give me troubles with CDT. I think that eclipse-emf 2.9 is meant to be used with eclipse 4.3 and my problem was generated by eclipse-emf 2.9 being put on AUR before eclipse 4.3 hit the official arch repos.

snack commented on 2013-07-28 08:58

@Stebalien: "again" applies to the fact that, as you can see below in the message list, this kind of breakage happened for 2.8.1 and 2.9.0. I posted two consecutive messages about this issue, the first on 2013-03-06 10:53 and the second on 2013-07-25 08:24.
About the fact that you don't see the problem, maybe it is strictly CDT-related and you don't use that extennsion? I don't know, but judging from the two most recentcomments by dront78 and zertyz I guess that it is a common issue.

zertyz commented on 2013-07-26 18:07

Thanks for providing the new version -- and, also, thanks for providing the old PKGBUILD. Guess that until the other maintainers update their dependent packages we must wait to use this new one.

dront78 commented on 2013-07-26 05:53

tnx 4 pkgbuild eclipse is ok now

Stebalien commented on 2013-07-25 13:17

I apologize for that. Here is a PKGBUILD for the old version (with the epoch bumped): https://gist.github.com/Stebalien/6079487

However, I don't see how "again" applies and, at least for me, launching eclipse is not sufficient to see the problem.

snack commented on 2013-07-25 08:24

Again, the new version (2.9.0-1) of eclipse-emf breaks the current eclipse version, at least when usign cdt (eclipse 4.2.2-1, eclipse-cdt 8.2.0-1). I understand that this is AUR and not an officially supported Arch repo; nevertheless, I think that a minimum level of testing should be done before releasing a new version: it is sufficient to install eclipse-emf 2.9.0-1 and then launch eclipse to see the problem.

snack commented on 2013-03-06 10:53

2.8.1 breaks all add-ons with the new eclipse 4.2.2. eclipse-emf 2.8.3 has been released upstream so please update the PKGBUILD. Thanks!

Stemp commented on 2013-02-01 17:48

Adding the mirror : Ialto(514)

Anonymous comment on 2013-02-01 17:27

Checksum problem:

==> Récupération des sources...
-> emf-xsd-SDK-2.8.1.zip trouvé
==> Validation des fichiers sources avec md5sums...
emf-xsd-SDK-2.8.1.zip ... ÉCHEC
==> ERREUR : Un ou plusieurs fichiers sont invalides !
==> ERREUR: Makepkg n'a pas pu construire eclipse-emf.

zman0900 commented on 2013-02-01 02:27

This won't download properly without adding something like "&mirror_id=1119" to the end of the source url.

wonder commented on 2012-10-04 11:46

which was the older version that is incompatible with eclipse 4.2.1? I'm thinking to add eclipse-emf to conflicts on eclipse.

m0rph commented on 2012-10-02 18:35

eclipse-emf breaks C/C++ support

scippio commented on 2012-10-02 11:19

new PKGBUILD:


# Maintainer: Stéphane Marguet (Stemp) <smarguet@gmail.com>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor: Corrado Primier <bardo@aur.archlinux.org>
# Contributor: Rubin Simons <rubin@xs4all.nl>

pkgname=eclipse-emf
pkgver=2.8.1
_reldate=201209170436
pkgrel=1
pkgdesc="EMF and XSD frameworks for the Eclipse platform"
arch=('any')
url="http://www.eclipse.org/modeling/emf/"
license=('EPL')
depends=('eclipse>=3.5')
changelog=ChangeLog
_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
source=("$_mirror/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/emf-xsd-SDK-${pkgver}.zip")
md5sums=('62d415f980ac0f246b503b12660b8b43')

package() {
_dest="${pkgdir}"/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse

cd "${srcdir}/eclipse"

# Features
find features -type f | while read _feature ; do
if [[ ${_feature} =~ (.*\.jar$) ]] ; then
install -dm755 "${_dest}"/${_feature%*.jar}
cd "${_dest}"/${_feature/.jar}
jar xf "${srcdir}/${_feature}"
else
install -Dm644 ${_feature} "${_dest}/${_feature}"
fi
done

# Plugins
find plugins -type f | while read _plugin ; do
install -Dm644 ${_plugin} "${_dest}/${_plugin}"
done
}

dront78 commented on 2012-10-02 05:34

please update because android tools not working for me
the workaround is to update eclipse via menu

kalib commented on 2012-09-04 12:50

You're rght. Just saw it. Sorry.

kalib commented on 2012-09-04 12:44

You're rght. Just saw it. Sorry.

Stemp commented on 2012-09-04 12:39

@kalib, eclipse.org is down.

kalib commented on 2012-09-04 12:31

The package is not downloading. Cannot run makepkg or even use yaourt to install it.

Stemp commented on 2012-08-07 07:13

@MyWorld, it's working for me. So it's probably a problem with your mirror.
Sadly I don't know what to do about it. Maybe I should use a «strong» mirror for everybody ? But which one ?

MyWorld commented on 2012-08-07 05:38

The source URL has changed again:


curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading emf-xsd-SDK-2.8.0.zip

Stemp commented on 2012-07-28 18:02

Update source URL, Thanks to Shanto

Shanto commented on 2012-07-28 17:49

@Stemp update the source URL to for proper mirror selection: http://www.eclipse.org/downloads/download.php?r=1&file=/modeling/emf/emf/downloads/drops/2.8.0/R201206080554/emf-xsd-SDK-2.8.0.zip

Stemp commented on 2012-03-06 17:12

Source updated, thank you cian1500ww

cian1500ww commented on 2012-03-06 16:46

I've uploaded it on S3 here: https://s3-eu-west-1.amazonaws.com/cianmcgovern/emf-xsd-SDK-2.7.2.zip

The current mirror must be throttled.

Ape commented on 2012-02-28 16:55

Doesn't anybody have a better mirror for emf-xsd-SDK-2.7.2.zip? The current mirror gives me download speeds about 10 KB/s which is just horribly slow.

Stemp commented on 2012-02-28 14:12

@huvber, probably because eclipse-gmf is seriously out of date

Anonymous comment on 2012-02-28 13:19

After upgrade i cannot use ecorediagram anymore... does anybody know why?

Stemp commented on 2012-02-22 17:57

Done, thanks tasidus.

tasidus commented on 2012-02-22 17:11

It fails to retrieve the source. Please change source url to:
http://download.eclipse.org/modeling/emf/emf/downloads/drops/${pkgver}/R${_reldate}/emf-xsd-SDK-${pkgver}.zip

2.7.x -> ${pkgver}

thanks

xyproto commented on 2011-12-14 17:10

Moved from [community] in connection with the Christmas Cleanup https://wiki.archlinux.org/index.php/Christmas_Cleanup.