Package Details: eclipse-gef 3.10.1-1

Git Clone URL: https://aur.archlinux.org/eclipse-gef.git (read-only)
Package Base: eclipse-gef
Description: GEF framework for the Eclipse platform
Upstream URL: http://www.eclipse.org/gef/
Licenses: EPL
Submitter: xyproto
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 255
Popularity: 1.447884
First Submitted: 2011-12-14 17:01
Last Updated: 2016-04-03 07:57

Latest Comments

Stebalien commented on 2016-04-06 14:39

@aaronfischer, there are no java-(7|8)-[open]jdk packages in either the AUR or the Arch Linux repositories.

aaronfischer commented on 2016-04-06 07:32

@Stebalien: java-8-jdk is also a java-environment which does not bring the jar-symlink.

@balwierz: For a quick walkaround, use the archlinux-java script to switch to java-(7|8)-openjdk for the build of this package.

Stebalien commented on 2015-09-02 15:14

@balwierze, no. eclipse-common depends on java-environment which is provided by either jdk7-openjdk or jdk8-openjdk (providing jar in /usr/lib/...) which depend on java-environment-common (providing a symlink to jar in /usr/bin).

balwierz commented on 2015-09-02 14:53

Something missing in build dependencies?

==> Starting package()...
/tmp/yaourt-tmp-user/aur-eclipse-gef/./PKGBUILD: line 30: jar: command not found
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build eclipse-gef.

planktonizer commented on 2014-09-30 06:31

pkgver=3.9.101
_reldate=201408150207
sha256sums=('07a8f38e67bf01c9fe74b930b23a22b2830049000a4ea2d631036d1901830ce5')
sha512sums=('dbb74764947fd49cdb0336ca66031c88c89fc90697336dcb70cc2ccc33e97aa9d169a813c8b7d2d79fcc1a0effe473945c4fc363927d6ebbdc043ad02c31e780')

planktonizer commented on 2014-07-16 16:16

@ngoonee
Yes it works, but it does break often when upgrading, e.g. no Android tools in Eclipse at all.

Usually you need the newest version of this, eclipse-emf and eclipse-wtp.
Some of these are updated rarely in AUR but the comments are helpful.

Also as suggested in eclipse-emf comments, remove your ~./eclipse folder and if that doesn't help workspace/.metadata.

ngoonee commented on 2014-07-07 03:09

Anyone using this? It seems to break one of my android projects and I'm not sure why. If anyone can confirm their android project works fine then I'll know the issue is on my end.

planktonizer commented on 2014-06-30 10:04

pkgver=3.9.100
_reldate=201405261516
sha256sums=('16cea32769af78f5c3b1e3300c3e9488fe0879edd3c70e066ad18707f020ec98')
sha512sums=('c0239a09d0c3d197365da296849f04c5b21ec61c5d1571fe8b68ad42eac88d891568ff551284b3d82996e044ae840a001c5fd20ee7fa52bca36512a3a097ad5d')

Lekensteyn commented on 2013-11-09 23:50

New version:
pkgver=3.9.1
_reldate=201308190730
md5sums=(9e46b98f5d92609064ded0f9f6816ddb)
sha256sums=(247f24aab10ac7c8484b9f8ce2d9c7a34b1f04531e33793124189ae2a53175d8)
sha512sums=(9ecb90d9935e2554654a5c9c140da8eaa054dbe9326abba0ee49f30a625d3507e30f00f02ca769344c9281ab74e8cf50500cde8ed1c937e8792ca94b6679b566)

luolimao commented on 2013-04-07 04:05

Yeah, and you don't need a build() function if it doesn't do anything. Also please quote $srcdir and $pkgdir when you use them.

mjob commented on 2013-02-01 11:16

This won't download properly without adding something like "&mirror_id=1" to the end of the source url.

m0rph commented on 2012-10-02 18:26

eclipse-gef breaks C++ support in eclipse

Stemp commented on 2012-03-06 17:15

Source updated, thank you cian1500ww

cian1500ww commented on 2012-03-06 16:56

Current mirror appears to be throttled, I've uploaded it on S3 as an alternative: https://s3-eu-west-1.amazonaws.com/cianmcgovern/GEF-ALL-3.7.2.zip

xyproto commented on 2011-12-14 17:11

Moved from [community] in connection with the Christmas Cleanup https://wiki.archlinux.org/index.php/Christmas_Cleanup.