Package Details: eclipse-pdt 4.0.0-1

Git Clone URL: (read-only)
Package Base: eclipse-pdt
Description: PHP Development Tools for Eclipse
Upstream URL:
Licenses: EPL
Submitter: None
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 79
Popularity: 0.341714
First Submitted: 2008-01-18 04:08
Last Updated: 2016-07-09 18:31

Dependencies (7)

Required by (2)

  • eclim (requires eclipse-pdt) (optional)
  • eclim-git (requires eclipse-pdt) (optional)

Sources (1)

Latest Comments

zeppelinlg commented on 2014-07-01 12:16


roheim commented on 2013-07-10 18:21


zeppelinlg commented on 2013-05-21 13:10

On the bgaleotti's PKGBUILD the ctrl+click don't work on the function/methode/variable

bgaleotti commented on 2013-03-15 14:57


Boris-B commented on 2012-10-28 18:54

This package stopped a good number of my eclipse from working. Everything was fixed when I removed it.

vEX commented on 2012-10-16 10:14

Try the following (can't remember if the source-url works or if I just downloaded it manually. But this builds the plugin find for me and makes it show up in Eclipse. I borrowed the code from some other eclipse package so all credits to someone else.

falmp commented on 2012-10-06 21:49

Thank you scippio. I installed it using the update site for now and it's working. Let's see if anyone knows how to fix this.

scippio commented on 2012-10-05 12:17

I don't know how install new 3.1.1 version into dropins :/ I copy features and plugins directories into dropins but it does not woek :(

scippio commented on 2012-10-05 00:43

wait a minutes.... i fix it..

falmp commented on 2012-10-03 20:09

I'm getting this error:

$ eclipse -clean
org.eclipse.equinox.p2.core.ProvisionException: Error: file:/usr/share/eclipse/dropins/pdt/ is not a valid extension location because it already contains a standard p2 repository file.
at org.eclipse.equinox.internal.p2.extensionlocation.ExtensionLocationMetadataRepositoryFactory.load(

And then eclipse opens with several missing icons and all broken.

Does anyone else is getting this error and/or know how to solve it?

scippio commented on 2012-10-03 17:47

adopted :)

Shanto commented on 2012-10-02 23:51

I have lost interest in PDT. Orphaned. Interested users, please adopt and maintain from this point. Thanks.

scippio commented on 2012-10-02 11:55

my function PKGBUILD:

# Maintainer: Shanto <>
# Contributor: Jonathan Wiersma <archaur at jonw dot org>

pkgdesc="PHP Development Tools for Eclipse"
arch=('i686' 'x86_64')
depends=('eclipse-dltk-core' 'eclipse-dtp' 'eclipse-wtp')
optdepends=('eclipse-rse' 'eclipse-pdt-debugger' 'php' 'xdebug' 'php-zend-debugger')

package() {
cd $srcdir/
install -dm755 $pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/
find Root_R3_0_WAVE9 -type f -exec install -Dm644 {} \
$pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/{} \;

falmp commented on 2012-08-09 03:34

==> Validating source files with md5sums... ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build eclipse-pdt.

Does anyone know of any other mirrors?

Anonymous comment on 2012-08-01 15:59

Unfortunately that link is no longer working

Anonymous comment on 2012-04-19 05:47

I've used this package in conjuntion with eclim. It does not work properly. I'd recommend using Eclipse's built in plugin management features using the Indigo's repositories instead.

Shanto commented on 2011-12-01 05:28

@act28: That's not PDT but an ad-hoc Eclipse bundle with/for zend-sdk.

Anonymous comment on 2011-11-30 21:49

The download source location has changed to

Anonymous comment on 2011-11-29 05:34 missing cannot be downloaded

Shanto commented on 2011-11-16 08:02

@emphire: No worries.. I did the same mistake (with myself) sometime in the last week. :)

emphire commented on 2011-11-15 20:55

Sorry, just glanced at the version number and saw 3.0.2 but I see that's the all-in-one, not the plugin.

Shanto commented on 2011-11-15 11:59

emphire: please tell us where/whats about the latest one.

enkeys commented on 2011-10-27 00:57

Wrong mirror. For example, use

emphire commented on 2011-06-30 21:09

I've updated the dependencies. Should have everything it needs now. I also upgraded to a maintenance version so it will work with eclipse-3.7.

imadalin commented on 2011-04-20 09:02

will try with this after I reinstall arch on my system, I'll digg into until I have it work.

d1t2hsu commented on 2011-04-17 22:01

same here, I guess that some dependecies are missing. It's work after some trial.
install these packages may help: eclipse-h2-database eclipse-dltk-core-index eclipse-mylyn eclipse-dltk-mylyn

konart commented on 2011-04-17 21:23

Same here

imadalin commented on 2011-04-07 21:27

I have a clean install of arch linux, with xfce, jdk and jre (not openjdk). I'm installing eclipse-pdt, it pulls all the other needed packages but when I start it php options aren't in eclipse. it doesn't give any errors.

emphire commented on 2011-03-29 19:49

Should work now that it's been updated to 2.2.0

sorcix commented on 2010-11-13 14:56

Getting nothing but errors after installing this on eclipse.

gary4gar commented on 2010-08-22 08:53

this does not build