Package Details: eclipse-php-bin 2:4.32-1

Git Clone URL: https://aur.archlinux.org/eclipse-php-bin.git (read-only, click to copy)
Package Base: eclipse-php-bin
Description: Highly extensible IDE (PHP version)
Upstream URL: https://www.eclipse.org/
Licenses: EPL
Conflicts: eclipse
Provides: eclipse
Submitter: altermetax
Maintainer: altermetax
Last Packager: altermetax
Votes: 2
Popularity: 0.46
First Submitted: 2024-06-13 02:18 (UTC)
Last Updated: 2024-06-13 21:58 (UTC)

Dependencies (3)

Required by (26)

Sources (3)

Latest Comments

brianbrodsky12 commented on 2024-06-15 04:01 (UTC)

@altermetax

Thank you, that resoveld the problem. Not sure why a clean build did not.

altermetax commented on 2024-06-15 03:02 (UTC)

@brianbrodsky12 are you sure you're using an up to date PKGBUILD? The error you're getting is related to a line that's no longer there. Try deleting ~/.cache/yay/eclipse-php-bin and then building the package again.

brianbrodsky12 commented on 2024-06-14 17:21 (UTC)

@altermetax

still getting same error:

==> Starting package()... chmod: cannot operate on dangling symlink '/home/brian/.cache/yay/eclipse-php-bin/pkg/eclipse-php-bin/usr/bin/eclipse' ==> ERROR: A failure occurred in package(). Aborting... -> error making: eclipse-php-bin-exit status 4 -> Failed to install the following packages. Manual intervention is required: eclipse-php-bin - exit status 4 [brian@brian-arch-desktop ~]$

altermetax commented on 2024-06-13 21:59 (UTC)

@brianbrodsky12 try again, it's fixed now.

brianbrodsky12 commented on 2024-06-13 16:43 (UTC)

Getting the following error trying to install:

==> Starting package()... chmod: cannot operate on dangling symlink '/home/brian/.cache/yay/eclipse-php-bin/pkg/eclipse-php-bin/usr/bin/eclipse' ==> ERROR: A failure occurred in package(). Aborting... -> error making: eclipse-php-bin-exit status 4 -> Failed to install the following packages. Manual intervention is required: eclipse-php-bin - exit status 4

brianbrodsky12 commented on 2021-09-15 22:47 (UTC)

@altermetax thank you so much. That fixed my issue.

altermetax commented on 2021-09-15 22:32 (UTC)

This is likely because eclipse.ini got changed, so the new eclipse.ini got saved to eclipse.ini.pacnew, this should fix it (make sure to backup eclipse.ini if you need it):

# mv /usr/lib/eclipse/eclipse.ini.pacnew /usr/lib/eclipse/eclipse.ini

brianbrodsky12 commented on 2021-09-15 22:27 (UTC)

getting error after updating when trying to open:

plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.2.200.v20210429-1609: cannot open shared object file: No such file or directory