Package Details: eclipse-pydev 5.1.2-1

Git Clone URL: https://aur.archlinux.org/eclipse-pydev.git (read-only)
Package Base: eclipse-pydev
Description: Python IDE for Eclipse
Upstream URL: http://pydev.org/
Licenses: EPL
Conflicts: eclipse-aptana
Submitter: None
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 351
Popularity: 1.382169
First Submitted: 2010-02-03 16:24
Last Updated: 2016-07-13 14:18

Latest Comments

godofgrunts commented on 2015-11-27 03:00

eclipse-pydev-mylyn doesn't seem to exist. Probably should be removed as an optional dependency.

arthurzam commented on 2015-04-27 11:28

@ryuzy , @CaptainHook8

I installed PyDev 4.0.0 and it works ok for me.

If you have a problem, use this old PKGBUILD:

http://pastebin.com/GVDqyzps

ryuzy commented on 2015-04-27 09:01

When I upgrade to the 4.0.0 Eclipse do not load it. It's like if pydev isn't installed.

MadPhysicist commented on 2015-04-23 01:44

Has anyone had a problem with this new version?

CaptainHook8 commented on 2015-04-22 12:36

Pydev 4.0.0 is out...could you please update the package?
Thank you very much.

sushidude commented on 2015-01-02 18:21

An orphan request was filed. Provided that it goes through and that there are no objections, I will take over as maintainer of this PKGBUILD.
For those of you that need a properly updated version of the PKGBUILD right now, here is one for 3.9.0. http://pastebin.com/raw.php?i=QiGSNa3E

sushidude commented on 2015-01-01 18:35

kiwisauce, this PKGBUILD has been outdated for almost two months. If you no longer have the time to maintain it, I would be willing to take over ownership.

pj1031999 commented on 2014-12-28 21:21

pkgver=3.9.0
md5sums=('160700fd2217d1a43a693da465cb17f7')

kiwisauce commented on 2014-11-04 22:07

Sorry, updated to 3.8.0

ronjouch commented on 2014-10-11 13:35

The minimal pkgver+md5sums bump suggested by acothi works fine. Thanks!

JDaff commented on 2014-10-07 11:43

pkgver=3.8.0

md5sums=('1101b0c48fa3ad643d2c98d6b36c5b65')


the only changes necessary

:b

kiwisauce commented on 2014-09-14 09:04

Updated to 3.7.1

baobab commented on 2014-09-11 20:17

PKGBUILD for 3.7.1 - http://pastebin.com/AtcFZqtE

$ poke maintainer

bhoppi commented on 2014-09-05 17:24

Release 3.7.1 is out

pekka commented on 2014-09-01 07:11

There is a new release 3.7.0

pekka commented on 2014-07-03 20:42

There is a new release 3.6.0

aaronki commented on 2014-06-04 11:03

I also had the problem that I couldn't see the plugin.
I executed eclipse as root once (sudo eclipse) and the plugin showed up. After that I also saw it when I executed eclipse as a normal user. This solution is not nice but better than recreating the workspace. Hope it helps you :)

aaronki commented on 2014-06-04 11:02

I also had the problem that I couldn't see the plugin. I executed eclipse as root once (sudo eclipse) and the plugin showed up. After that I also could also see it when I executed eclipse as a normal user. This solution is not nice but better than recreating the workspace.

kiwisauce commented on 2014-04-05 18:09

Thanks, updated.

pekka commented on 2014-03-28 17:25

pkgver=3.4.1
md5sums=('f735f8f6f022c2865f4e903b013f980d')

pekka commented on 2014-03-21 19:04

New relase 3.4.1

Boehemyth commented on 2014-02-26 18:05

I have the same problem as hobarrera. Does anybody know what causes this?

hobarrera commented on 2014-02-11 13:13

After every update, when I next run eclipse, it fails to detect the plugin until I delete/recreate my workspace. I've had this issue since always, and on every PC. Is there a workaround?

kiwisauce commented on 2014-02-05 12:11

Updated, thanks.

pekka commented on 2014-02-04 15:52

There is a new release 3.3.3

kiwisauce commented on 2014-01-26 13:28

Updated to 3.2.0.

pekka commented on 2014-01-11 20:47

pkgver=3.2.0
md5sums=('4ddd60b0adc688fe78fa3fc412ef7639')

PiC0 commented on 2013-12-18 16:48

There is a new release 3.1.0

pkgver=3.1.0
depends=('java-environment>=7' 'eclipse>=3.8')
md5sums=('614a23acbd6a0df777dffce070f06177')

Regards,

kiwisauce commented on 2013-11-20 21:52

Updated, thanks.

pekka commented on 2013-11-08 15:01

pkgver=3.0
md5sums=('b10b4e94e97272dda0190449ad30579f')
depends= dont know, ('eclipse>=3.6 or eclipse>=4.3') or something.

kiwisauce commented on 2013-10-27 11:02

Thanks, updated.

NiteiaTt commented on 2013-10-21 14:30

2.8.2 is out

kiwisauce commented on 2013-08-02 11:18

Thx, updated.

cle1109 commented on 2013-08-02 11:13

2.8.0 is out
2.8.1 is out

pekka commented on 2013-06-13 23:17

2.7.4 is out 2013-05-16
2.7.5 is out 2013-05-28

jlanzobr commented on 2013-05-27 18:20

Updating a couple lines in the PKGBUILD gets you the latest version:
pkgver=2.7.4
md5sums=('c02f977afb5a03a13c1b9d25ef39ced0')

marcs commented on 2013-05-24 22:18

2.7.4 is out :)

kiwisauce commented on 2013-03-07 17:50

Sorry, updated to 2.7.1.

hobarrera commented on 2013-03-07 17:26

Here's an updated PKGBUILD for 2.7.1:
https://gist.github.com/hobarrera/5109920

intgr commented on 2013-03-07 09:23

kiwisauce, if I'm not mistaken, this package has not been updated since last October. Please update or disown.

MatejLach commented on 2012-12-24 15:52

Here's the correct md5sum for the latest release '30e465afacbc62e6827eaffd90b3b100'

ejno commented on 2012-11-18 20:57

to get the latest, set pkgver=2.7.1

Anonymous comment on 2012-10-01 12:46

I'm having the same problem as nap3um before.

Any idea how to fix it? I tried removing the tmp/yaourt/aur-pydev but that only let it redownload the package.
Also looked into PKG, but there is nowhere any removing, also it's weird Can't remove already-existing dir, why? Isn't that why somebody removes it in the first place, because it exists..... Didn't really understand that message. So can it remove a non existing dir only?

Thanks for any help.

plugins/org.python.pydev.debug_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.6.0.2012062818/icons/ovr16/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/xml/sax/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/xml/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/jysrc/tests/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/xml/dom/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/jysrc/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/encodings/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/xml/sax/drivers2/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/pawt/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.6.0.2012062818/Lib/email/: Can't remove already-existing dir
plugins/org.python.pydev.parser_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.ast_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/templates/google_app_engine/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/templates/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/templates/google_app_engine/hello_world/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/templates/google_app_engine/hello_webapp_world/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.6.0.2012062818/templates/google_app_engine/ask_login/: Can't remove already-existing dir
plugins/com.python.pydev.debug_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/com.python.pydev.debug_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.refactoring_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.django_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.django_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.6.0.2012062818/templates/: Can't remove already-existing dir
plugins/org.python.pydev.help_2.6.0.2012062818/html/: Can't remove already-existing dir
plugins/org.python.pydev.help_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.codecompletion_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.red_core_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.core_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.core_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/icons/old/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/tests_runfiles/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/icons/new/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/tests/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/tests_runfiles/samples/nested_dir/nested2/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/tests_runfiles/samples/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/third_party/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/third_party/wrapped_for_pydev/ctypes/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/third_party/wrapped_for_pydev/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/third_party/wrapped_for_pydev/ctypes/macholib/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/pysrc/tests_runfiles/samples/nested_dir/nested3/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev_2.6.0.2012062818/schema/: Can't remove already-existing dir
plugins/com.python.pydev.fastparser_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.refactoring_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/org.python.pydev.refactoring_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.analysis_2.6.0.2012062818/icons/: Can't remove already-existing dir
plugins/com.python.pydev.analysis_2.6.0.2012062818/META-INF/: Can't remove already-existing dir
bsdtar: Error exit delayed from previous errors.

kiwisauce commented on 2012-06-29 13:02

Updated to 2.6.0!

kiwisauce commented on 2012-04-09 10:48

Updated to 2.5.0!

dcelasun commented on 2012-04-08 18:35

2.5 is out.

Anonymous comment on 2012-02-25 14:14

Eclipse prints this to the console:
*sys-package-mgr*: can't create package cache dir, '/usr/share/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev.jython_2.2.2.2011082312/cachedir/packages'

does not seem essential though

kiwisauce commented on 2012-01-31 12:03

Updated download URI, thanks Chingzilla and xvalentinex!

Anonymous comment on 2012-01-29 07:37

I had a problem where the file was not downloading. Not sure if sourceforge's download urls have changed but I found this fixed my problem.

--- PKGBUILD.old 2011-12-22 02:18:21.000000000 -0700
+++ PKGBUILD 2012-01-29 00:34:21.068895431 -0700
@@ -10,7 +10,7 @@
depends=('eclipse')
makedepends=('unzip')
conflicts=('eclipse-aptana')
-source=("http://downloads.sourceforge.net/project/pydev/pydev/PyDev%20${pkgver}/PyDev ${pkgver}.zip")
+source=("http://sourceforge.net/projects/pydev/files/pydev/PyDev%20${pkgver}/PyDev%20${pkgver}.zip/download")
sha256sums=('7cee79ac2a9b5176146772e05d3fc63069fcbb9700c098fcf84fd932a4bf83f2')

napa3um commented on 2012-01-23 09:43

==> Распаковка исходных файлов...
-> Извлечение PyDev%202.3.0.zip с помощью bsdtar
plugins/com.python.pydev.codecompletion_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.refactoring_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.core_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.core_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.parser_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.refactoring_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.refactoring_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.help_2.3.0.2011121518/html/: Can't remove already-existing dir
plugins/org.python.pydev.help_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/ThirdParty/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/ThirdParty/wrapped_for_pydev/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/icons/old/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/pydev_sitecustomize/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/icons/new/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/ThirdParty/wrapped_for_pydev/ctypes/macholib/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/schema/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/ThirdParty/pep8/: Can't remove already-existing dir
plugins/org.python.pydev_2.3.0.2011121518/PySrc/ThirdParty/wrapped_for_pydev/ctypes/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/tests/samples/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/tests/samples/nested_dir/nested2/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/tests/samples/nested_dir/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/tests_python/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/pysrc/tests/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/schema/: Can't remove already-existing dir
plugins/org.python.pydev.debug_2.3.0.2011121518/icons/ovr16/: Can't remove already-existing dir
plugins/org.python.pydev.red_core_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/templates/google_app_engine/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/templates/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/templates/google_app_engine/hello_world/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/templates/google_app_engine/hello_webapp_world/: Can't remove already-existing dir
plugins/org.python.pydev.customizations_2.3.0.2011121518/templates/google_app_engine/ask_login/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/xml/sax/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/xml/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/jysrc/tests/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/xml/dom/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/jysrc/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/encodings/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/xml/sax/drivers2/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/pawt/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/: Can't remove already-existing dir
plugins/org.python.pydev.jython_2.3.0.2011121518/Lib/email/: Can't remove already-existing dir
plugins/org.python.pydev.django_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.django_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.ast_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/org.python.pydev.django_templates_2.3.0.2011121518/templates/: Can't remove already-existing dir
plugins/com.python.pydev.analysis_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/com.python.pydev.analysis_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.fastparser_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev.debug_2.3.0.2011121518/icons/: Can't remove already-existing dir
plugins/com.python.pydev.debug_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
plugins/com.python.pydev_2.3.0.2011121518/META-INF/: Can't remove already-existing dir
bsdtar: Error exit delayed from previous errors.
==> ОШИБКА: Не удалось распаковать PyDev%202.3.0.zip
Преждевременный выход...

Anonymous comment on 2011-12-29 17:35

Needed to add '%20' to the source url.

--- PKGBUILD.orig 2011-12-29 10:34:54.719010307 -0700
+++ PKGBUILD 2011-12-29 10:35:10.839010379 -0700
@@ -10,7 +10,7 @@
depends=('eclipse')
makedepends=('unzip')
conflicts=('eclipse-aptana')
-source=("http://downloads.sourceforge.net/project/pydev/pydev/PyDev%20${pkgver}/PyDev ${pkgver}.zip")
+source=("http://downloads.sourceforge.net/project/pydev/pydev/PyDev%20${pkgver}/PyDev%20${pkgver}.zip")
sha256sums=('7cee79ac2a9b5176146772e05d3fc63069fcbb9700c098fcf84fd932a4bf83f2')

kiwisauce commented on 2011-12-22 09:18

Updated to 2.3.0!

Anonymous comment on 2011-12-22 08:14

Version 2.3.0 is out! :-)

kiwisauce commented on 2011-11-03 10:51

:-)

Anonymous comment on 2011-11-03 10:50

oops, you were faster than me ;) Thanks for the update -- works fine here.

kiwisauce commented on 2011-11-03 10:49

Yes, i did it?!

Anonymous comment on 2011-11-03 10:48

PyDev 2.2.4 was just released. It builds and installs without any problems after simply updating pkgver and sh256sums in PKGBUILD.

kiwisauce commented on 2011-11-03 10:43

Updated to 2.2.4!

elk commented on 2011-10-22 21:25

It works fine with Eclipse 3.7.1-2 and JKD7 7.b147_2.0-2 on a fresh system.
So I guess the problem is in your configuration, statc.

Anonymous comment on 2011-10-14 07:42

2.2.3 doesn't work for me with recent Eclipse 3.7-1. Eclipse just hangs at startup. It prints lots of Java exception traces when run as "eclipse -debug -consolelog".

kiwisauce commented on 2011-10-13 14:03

Just updated to 2.2.3!

kiwisauce commented on 2011-08-24 14:32

Updated to 2.2.2!

kiwisauce commented on 2011-07-15 09:40

Updated to 2.2.1!

kiwisauce commented on 2011-06-27 13:17

Updated to 2.2.0!

Evilandi666 commented on 2011-06-26 14:32

Actual pydev is 2.2 I think

kiwisauce commented on 2011-06-23 14:33

Thanks, fixed.

Anonymous comment on 2011-06-23 14:25

Hi guys, I think the Tarball is not properly packaged, the folder name is "New Folder". Look at this:

tar xvzf eclipse-pydev.tar.gz
New Folder/
New Folder/PKGBUILD

kiwisauce commented on 2011-06-07 09:16

Updated to 2.1.0!

ultramancool commented on 2011-04-15 13:51

2.0.0 doesn't seem to do anything in eclipse.

kiwisauce commented on 2011-04-05 12:53

Updated to 2.0.0!

kiwisauce commented on 2011-04-05 12:01

Updated to 2.0.0!

kiwisauce commented on 2011-03-12 14:10

Do you have the Aptana-Studio-plugin installed? If yes, than upgrade it to 3.2 with the following update site:
http://update.aptana.com/update/studio/3.2/

Does it work?

rogorido commented on 2011-03-10 09:06

thanks for providing the package!
pydev is although not starting with the last eclipse update. I get:
Could not open the editor: No editor descriptor for id org.python.pydev.editor.PythonEditor

kiwisauce commented on 2011-02-10 10:39

Thanks, updated.

rferrazz commented on 2011-02-07 10:17

i had some trouble installing new release due to folder permissions problems, after changing th permission of /usr/share/eclipse/dropins/pydev it works again.

Here is how i did that:
chmod -R a+x /usr/share/eclipse/dropins/pydev

Maybe you can modify the PKGBUILD

kiwisauce commented on 2011-02-06 16:58

Thanks, updated.

kiwisauce commented on 2011-02-06 16:43

Erm?!. It is

source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%20${pkgver}/Pydev%20$pkgver.zip")

?!

utdemir commented on 2011-02-06 16:03

It didn't worked me correctly, said cannot find or open Pydev 1.6.5.zip, so I managed to work it with changing:

source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%20${pkgver}/Pydev%20$pkgver.zip")

to

source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%20${pkgver}/Pydev $pkgver.zip")

utdemir commented on 2011-02-06 15:33

It didn't worked me correctly, said cannot find or open Pydev 1.6.5.zip, so I managed to work it with changing:

source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%20${pkgver}/Pydev%20$pkgver.zip")

to

source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%20${pkgver}/Pydev $pkgver.zip")

kiwisauce commented on 2011-02-05 21:43

Adopted and updated to 1.6.5

kiwisauce commented on 2011-01-19 17:20

1.6.4 > http://aur.pastebin.com/wLunkzte

kevku commented on 2010-09-21 20:04

1.6.2 > http://aur.pastebin.com/RBjb0g8s

kevku commented on 2010-08-13 11:03

1.6.1 > http://aur.pastebin.com/6mStCnTX

josesj commented on 2010-07-21 11:47

Hello,

Here is the PKGBUILD for version 1.6.0:


# Contributor: Jesus Jerez <jerezmoreno@gmail.com>
pkgname="eclipse-pydev"
pkgver="1.6.0"
pkgrel="1"
pkgdesc="Python IDE for Eclipse"
url="http://pydev.org/"
license=('custom' 'EPL' 'Eclipse public license')
arch=('i686' 'x86_64')
depends=('eclipse' 'python')
makedepends=('unzip')
source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%201.6.0/org.python.pydev.feature-1.6.0.2010071813.zip")
md5sums=('05bcd2986d7dd302556f25faefca5f68')

build() {
mkdir -p ${pkgdir}/usr/share/eclipse/
cp -R ${srcdir}/features ${pkgdir}/usr/share/eclipse/
cp -R ${srcdir}/plugins ${pkgdir}/usr/share/eclipse/
}

lepokle commented on 2010-04-07 14:03

The last comment should be a question :-)
Can I upload an updated PKGBUILD?

Best regards,
Leo

lepokle commented on 2010-04-07 14:02

Hello,

can only the maintainer update the PKGBUILD.
Here is the PKGBUILD for version 1.5.6:

# Contributor: Jesus Jerez <jerezmoreno@gmail.com>
pkgname="eclipse-pydev"
pkgver="1.5.6"
pkgrel="1"
pkgdesc="Python IDE for Eclipse"
url="http://pydev.org/"
license=('custom' 'EPL' 'Eclipse public license')
arch=('i686' 'x86_64')
depends=('eclipse' 'python')
makedepends=('unzip')
source=("http://downloads.sourceforge.net/project/pydev/pydev/Pydev%201.5.6/org.python.pydev.feature-1.5.6.2010033101.zip")
md5sums=('b95c3350016506ae9684462582c4ed03')

build() {
mkdir -p ${pkgdir}/usr/share/eclipse/
cp -R ${srcdir}/features ${pkgdir}/usr/share/eclipse/
cp -R ${srcdir}/plugins ${pkgdir}/usr/share/eclipse/
}


Best regards,
Leo