Package Details: eclipse-subversive 3.0.1.I20150722_1700-2

Git Clone URL: https://aur.archlinux.org/eclipse-subversive.git (read-only)
Package Base: eclipse-subversive
Description: Eclipse plug-in that provides Subversion support.
Upstream URL: http://www.eclipse.org/subversive/
Licenses: EPL
Submitter: qwak
Maintainer: benjarobin
Last Packager: benjarobin
Votes: 32
Popularity: 0.000241
First Submitted: 2007-05-02 09:44
Last Updated: 2015-07-26 19:24

Latest Comments

benjarobin commented on 2012-04-18 18:07

The packages svn connector / svnkit are updated, please update the PKGBUILD : http://pastebin.archlinux.fr/438920

emphire commented on 2011-07-04 18:24

Actually, it might be best not to make this package depend on eclipse-subversive-svn-connector. I have orphaned it as the current version is newer than the one used by subversive and it is too difficult to track down older versions constantly.

Please use this PKGBUILD as the current one doesn't work with the features left un-archived:
http://pastebin.com/2kzKB6Nx

emphire commented on 2011-07-04 17:41

I have updated eclipse-subversive-svn-connector-svnkit and eclipse-subversive-svn-connector. You can use them with the following PKGBUILD if you care to update:
http://pastebin.com/dqxPJHWu

Note: I noticed that current PKGBUILD installs a lot of extra files that are not needed and is not un-archiving the features which causes issues with eclipse-3.6. I've fixed that up in the PKGBUILD I've pasted in.

emphire commented on 2011-07-01 19:19

Just a note that I have adopted eclipse-subversive-svn-connector and will fix it up soon. I emailed the maintainer if this package and he said he doesn't have time to update this package but will later. I'll paste a newer package the comments on here when I get the dependencies updated.

Anonymous comment on 2011-07-01 18:46

Or use http://aur.pastebin.com/YCnVaAcC
It's the PKGBUILD without the SVN connector dependency (eclipse-subversive-svn-connector), because the AUR packages for that are also broken, outdated and unmaintained.
Obvious disadvantage: the connectors will be installed on a per-user basis, not system-wide.

kiwisauce commented on 2011-01-19 19:06

http://aur.pastebin.com/PEi6USHQ This PKGBUILD is now compatible with the eclipse-subversive-svn*-packages. Let me adopt this package, if you want. Thanks.

kiwisauce commented on 2011-01-19 18:59

Take this PKGBUILD:

pkgname=eclipse-subversive
pkgver=0.7.9.I20101203
pkgrel=1
pkgdesc="Eclipse plug-in that provides Subversion support."
arch=('i686' 'x86_64')
url="http://www.eclipse.org/subversive/"
license=('EPL')
depends=('eclipse' 'eclipse-subversive-svn-connector-svnkit')
source=(http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/subversive/0.7/builds/Subversive-incubation-${pkgver}-1700.zip)

md5sums=('213f19c4ec523eba3e1000683a61eac3')

build() {
_dest="${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse"
cd "$srcdir"

install -d -m0755 $_dest/{features,plugins}
cp -r {plugins,features}/ $_dest/

find $pkgdir -type f -exec chmod 0644 {} \;
}

Anonymous comment on 2010-11-10 10:09

New versions out here: http://www.eclipse.org/subversive/downloads.php

Older links disappear in Eclipse repositories :(