Package Details: eclipse-wtp 3.8.0-1

Git Clone URL: https://aur.archlinux.org/eclipse-wtp.git (read-only)
Package Base: eclipse-wtp
Description: Webtools framework for the Eclipse platform
Upstream URL: http://www.eclipse.org/webtools/
Licenses: Eclipse Public License
Provides: eclipse-wtp-wst
Submitter: None
Maintainer: arthurzam
Last Packager: arthurzam
Votes: 276
Popularity: 0.203316
First Submitted: 2006-05-21 16:09
Last Updated: 2016-06-30 17:01

Latest Comments

petterk commented on 2016-02-08 14:26

ERROR: license should be an array

dsboger commented on 2015-07-24 16:40

Hello, 3.7 is out. Also, please update the PKGBUILD to install to /usr/lib instead of /usr/share.
Thanks!

arthurzam commented on 2015-03-16 07:03

@zatricky

I searched for a more "direct" source, but didn't find one.

Will it help if for minor builds (change in third version number), I will put the previous version (for example 3.6.0) and xdelta in sources?
Also, I can put third party mirror, but I will need suggestions of site.

zatricky commented on 2015-03-16 06:41

Hey, arthurzam

I don't suppose there is an alternative mirror / download location? The Eclipse site seems to throttle downloads - and this plugin is particularly large.

At work I'm on a gigabit connection (I work for an ISP) - yet the 189MB took 18 minutes to download (1.4Mbps).

Alternatively, is there perhaps a more "direct" source might prove a lot better. Not so much because of the speed but because of the wasted download. I compared the .zip from today to the .zip from 4 days ago. An xdelta of the raw .zip files is 27MB. After uncompressing the .zip files and dumping it into an uncompressed .tar, the difference was only 7.6MB. This means all users are today downloading 189MB in order to get 7.6MB (possibly less) in changes.

Secondary note: The .zip includes a large number of files (~960) , most of which are also already compressed (.jar and .gz files for example). I know it would involve listing a lot more source files - but perhaps sourcing the content that way would decrease the download considerably.

Marcel_K commented on 2015-01-13 23:22

Please add double quotes around all instances of $srcdir, $pkgdir and in your case, ${_dest}, to allow for spaces in directory names.

planktonizer commented on 2014-06-30 10:00

pkgver=3.6.0
_pkgdate=20140602160322
md5sums=('259601b3867b1ebe64c4bf15b11c793e')

EsterniTY commented on 2014-03-11 22:21

New version available

pkgver=3.5.2
_pkgdate=20140217150812
md5sums=('8e03d3abd9419db5d0160ae2c1d59ba3')

djmwj1 commented on 2013-12-27 22:19

Thanks Lekensteyn

Lekensteyn commented on 2013-11-10 00:00

New version:
pkgver=3.5.1
_pkdate=20130913223750
md5sums=(e9d1002fb1fcbd1229d95d2f3d797359)

zeppelinlg commented on 2013-08-05 09:47

WTP 3.5.0-20130610150119 Released!

xgdgsc commented on 2013-03-21 06:57

WTP 3.4.2 Released!

zertyz commented on 2013-02-04 14:32

+1 for "&mirror_id=1"

mjob commented on 2013-02-01 11:18

This won't download properly without adding something like "&mirror_id=1" to the end of the source url.

Anonymous comment on 2013-01-16 10:38

@Shanto: Updated PKGBUILD to adhere to the Eclipse packaging guidelines (https://wiki.archlinux.org/index.php/Eclipse_plugin_package_guidelines). Please have a look at http://sprunge.us/ZERU for the PKGBUILD file.

M0Rf30 commented on 2012-09-29 14:28

3.4.1 is out

bzt commented on 2012-07-23 07:58

PKGBUILD for 3.4.0:

http://pastebin.com/dwna54LT

idovitz commented on 2012-07-12 11:05

Can you remove:
provides=('eclipse-wtp-wst')

because i want to make a new package for liferay ide plugin (eclipse-liferay). That needs wst.. With your package i get eclipse errors.

idovitz commented on 2012-07-12 11:05

Can you remove:
provides=('eclipse-wtp-wst')

because i want to make a new package for liferay ide plugin (eclipse-liferay). That needs wst.. With your package i get eclipse errors.

Shanto commented on 2012-03-02 13:28

@kjozsa Did you try "eclipse -clean"?

kjozsa commented on 2012-03-01 10:46

are you sure the new package is correct? Appearently, the upgrade made my Servers view disappear completely somehow.. Can you please double-check if it works correctly for you?

Neschur commented on 2012-02-28 15:50

new version 3.3.2 (eclipse updated to 3.7.2)

cebru commented on 2011-03-05 11:29

For version 3.2.3, just update the PKBGUILD with the following:

pkgver=3.2.3
_pkgdate=20110217214612
md5sums=('3335ebd6130aa576a57f43419a324acf')

mortzu commented on 2010-09-29 11:18

update or orphan

lepokle commented on 2010-08-29 10:50

Here is an updated PKBUILD:

http://aur.pastebin.com/download.php?i=7Nc3ZVyK

Best regards,
Leo

Anonymous comment on 2010-06-30 01:34

Last version (2010-06-29):
pkgver=3.2.0
_pkgdate=20100615235519
md5sums=('f45a79e866e75197ac2538b6b57b9ef1')

anpieber commented on 2010-05-27 12:48

in addition it will help to add the following to the pkgbuild

provides=('eclipse-wtp-wst')

thank you

anpieber commented on 2010-05-27 12:28

ok, updating the following params in pkgbuild a) updates it b) make it work again

pkgver=3.1.2
_pkgdate=20100211202452
source=("http://eclipse.mirror.garr.it/mirrors/eclipse//webtools/downloads/drops/R$pkgver/R-$pkgver-$_pkgdate/wtp-R-$pkgver-$_pkgdate.zip")
md5sums=('e2c17a1d8b475bca50ac9e96ce23564d')

cebru commented on 2010-05-12 14:47

Download no longer works.