Package Details: ecodmsclient 16.09.1-2

Git Clone URL: https://aur.archlinux.org/ecodmsclient.git (read-only)
Package Base: ecodmsclient
Description: Document Management Software
Upstream URL: http://www.ecodms.de/index.php/de/
Licenses: custom
Submitter: tuxflo
Maintainer: leachim.remlov
Last Packager: tuxflo
Votes: 7
Popularity: 0.908525
First Submitted: 2015-12-08 13:03
Last Updated: 2017-02-07 14:13

Latest Comments

1 2 Next › Last »

theWeird commented on 2018-12-04 12:07

Do you plan to update this package for the recently available 18.09 deb packages?

Helloagain commented on 2018-08-30 14:27

@Drachenkatze:

I need to install qt5-webkit in order to be able to build the package. This is missing in your PKGBUILD

Helloagain commented on 2018-08-29 23:58

Thanks @Drachenkatze for your patch.

Any news on this one here?

renne commented on 2018-08-17 08:30

curl: (22) The requested URL returned error: 404 Not Found ==> FEHLER: Fehler beim Download von http://www.ecodms.de/ecodms_160964/xenial/./ecodmsclient-16.09-2-0_amd64.deb Breche ab...

Drachenkatze commented on 2018-06-26 14:24

I have patched the ecodms client for the latest version. I also included sane in the deps as this is required.

For reference, until my patch is incorporated, here's the complete PKGBUILD:

# Maintainer: tuxflo

pkgname=ecodmsclient
pkgver=16.09.3
pkgrel=3
pkgdesc="Document Management Software"
arch=('x86_64')
url="http://www.ecodms.de/index.php/de/"
license=('custom')
depends=('bash' 'libappindicator-gtk2' 'qt5-svg' 'qt5-x11extras' 'libpng12' 'freeimage' 'libksane')
options=('!strip')
install=${pkgname}.install

source_x86_64=("ecodmsclient-${pkgver}_amd64.deb::http://www.ecodms.de/ecodms_160964/xenial/./ecodmsclient-16.09-3-0_amd64.deb")

md5sums_x86_64=('bd9e934952deec44caddcf3193fd7a17')

package() {
  cd "${srcdir}"
  tar -xf data.tar.xz

# Install
  cp -dr --no-preserve=ownership etc opt usr "${pkgdir}"/

}

Also it's required to add a symlink to PCRE, here's the ecodmsclient.install file:

post_install() {
  # Create symlink to the PCRE library which is required by ecodms
  ln -s /usr/lib/libpcre.so /usr/lib/libpcre.so.3

  echo "Execute /opt/ecodms/ecodmsclient/ecodmsconmgr.sh to connect to the server"
}

post_upgrade() {
  post_install
}

post_remove() {
  rm -rf /opt/ecodms/ecodmsclient
}

# vim: ts=2 sw=2 et:

Nolle commented on 2018-01-22 09:17

Ecodms released a new version.

That leads to "ERROR: Failure while downloading http://www.ecodms.de/ecodms_160964/xenial/./ecodmsclient-16.09-2-0_amd64.deb"

changing the PKGBUILD to

source_x86_64=("ecodmsclient-${pkgver}_amd64.deb::http://www.ecodms.de/ecodms_160964/xenial/./ecodmsclient-16.09-3-0_amd64.deb")

and correcting the md5sum got it to work

oozaru_hunter commented on 2017-08-12 22:54

It works now after linking
ln -s /usr/lib/libpcre.so.1.2.9 /usr/lib/libpcre.so.3

oozaru_hunter commented on 2017-08-12 21:54

The client fails to start with:
./ecodmsclient: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory

-> I installed sane

Then it fails with:
./ecodmsclient: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

-> However, pcre is already installed...

leachim.remlov commented on 2017-07-29 19:06


I would be hooked. I could keep it up.

tuxflo commented on 2017-05-17 10:57

I switched to an Ubuntu based distribution on most of my systems now. Somebody interested in maintaining this package?