Package Details: econnman-git 1.1.0.r19.g5959946-1

Git Clone URL: https://aur.archlinux.org/econnman-git.git (read-only)
Package Base: econnman-git
Description: Enlightenment ConnMan user interface - Development version
Upstream URL: https://phab.enlightenment.org/w/projects/econnman/
Licenses: LGPL3
Conflicts: econnman
Provides: econnman=1.1.0.r19.g5959946
Submitter: Scimmia
Maintainer: Tido.com
Last Packager: Scimmia
Votes: 32
Popularity: 0.042454
First Submitted: 2013-03-14 16:09
Last Updated: 2015-06-08 17:13

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

Scimmia commented on 2014-06-21 12:35

xangelux, thanks, I had missed something when changing how the install commands were used.

xangelux commented on 2014-06-21 06:53

I forgot to tell you, in the PKGBUILD file, change the line
install -Dm644 AUTHORS "$pkgdir/usr/share/doc/$_pkgname/" AUTHORS ChangeLog NEWS README

to

install -Dm644 AUTHORS ChangeLog NEWS README "$pkgdir/usr/share/doc/$_pkgname/"

I found it some time ago and forgot to report it.

Scimmia commented on 2013-12-17 15:51

Changing permissions doesn't need to be done in a post install script, it can be done just fine in the PKGBUILD. That's where I have it, but I just have it set to 666 instead of changing the group.

T_UNIX commented on 2013-12-17 15:18

Please add a post-installation section to the PKGBUILD to change the permissions of /var/lib/connman/econnman.config to be read+writeable by e.g. the 'users' group.
That's necessary to make econnman support 802.1x wireless networks when executed as ordinary user, who's supposedly member of the group 'users'.

Scimmia commented on 2013-10-17 03:20

A small patch was just accepted (but not yet committed) upstream to make this compatible with python3. Any objections to switching this package deps? It would simplify the PKGBUILD a bit and it's always nice to use the latest versions.

Scimmia commented on 2013-04-05 05:12

This package how now been updated for pacman/makepkg 4.1. It will no longer work with makepkg 4.0.3 or earlier.

If you've built this package before, it's best if you remove the existing "src" dir to make sure everything's clean, but it's not required. Either way, the new version will re-download the source.

You'll notice that the pkgver has changed significantly. If you're using an AUR helper that tries to check the package version to see if it needs to rebuild, it won't like this so please reinstall this package manually. Going forward, though, this scheme should work much better with those AUR helpers. I could add an epoch to the PKGBUILD, but then we'd be stuck with it forever. Since this should be a one time thing, I think it's better to just ask people to install.

Scimmia commented on 2013-03-14 16:14

*** Important ***

Enlightenment is in the process of switching from SVN to Git and this program has now been switched. Users of the release version of Enlightenment in Extra should switch to the release version of EConnman:
https://aur.archlinux.org/packages/econnman/
While users of the Git version of Enlightenment should switch to the Git version of this package:
https://aur.archlinux.org/packages/econnman-git/
Please make this switch as soon as possible, because this package will be deleted after a suitable notification period.

Scimmia commented on 2013-03-14 00:23

Users of EFL/Enlightenment in the Extra repo should start transitioning over to the new package econnman here in the AUR:

https://aur.archlinux.org/packages/econnman/

I was unaware of this release until recently. Because this is available, I just sent patches upstream to switch this package over to the new python bindings (python2-efl-svn), which require efl-svn. If they're accepted, this package will no longer work with the release versions.

This is a much better solution than the ridiculous sed command I currently have in the post-install script.

Sorry for any inconvenience.

Scimmia commented on 2013-02-26 23:45

If you are user of the svn/git version of Enlightenment, please upgrade to python2-efl-svn before upgrading this package. I added a post install script to this that will adapt it to the new bindings.

If you are a user of the normal version of Enlightenment in the Extra repo, this shouldn't affect you at all.

Scimmia commented on 2013-02-23 05:06

Yes, but I can't say when. The plan is to switch everything to git and shut down svn, but they're doing things in stages. There is a lot in their svn repo, so it could take a while unless they decide to just do a huge batch or two with the lesser used stuff.

All comments