Package Details: ede 2.1-1

Git Clone URL: https://aur.archlinux.org/ede.git (read-only)
Package Base: ede
Description: The lightweight Equinox Desktop Environment
Upstream URL: http://equinox-project.org/
Licenses: LGPL
Conflicts: pekwm
Provides: pekwm
Submitter: haawda
Maintainer: keenerd
Last Packager: keenerd
Votes: 20
Popularity: 0.000041
First Submitted: 2008-11-09 11:03
Last Updated: 2015-06-13 04:24

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Anonymous comment on 2012-06-09 06:02

add libstdc++5 to ede and edelib i'm not sure if makedep or dep
add -fPIC in builds CFLAGS and CXXFLAGS for ede and edelib for fix the problem in build applets

Anonymous comment on 2012-05-26 23:13

As with tintzin, ede-panel fails to load for me:
[edelib] src/Window.cpp:53: loading 'edeneu' theme
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/start_menu.so' : '/usr/share//ede/panel-applets/start_menu.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/quick_launch.so' : '/usr/share//ede/panel-applets/quick_launch.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/pager.so' : '/usr/share//ede/panel-applets/pager.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:108: Loading class Hider
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/clock.so' : '/usr/share//ede/panel-applets/clock.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/taskbar.so' : '/usr/share//ede/panel-applets/taskbar.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/keyboard_layout.so' : '/usr/share//ede/panel-applets/keyboard_layout.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:108: Loading class CPUMonitor
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/mem_monitor.so' : '/usr/share//ede/panel-applets/mem_monitor.so: cannot open shared object file: No such file or directory'
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/system_tray.so' : '/usr/share//ede/panel-applets/system_tray.so: cannot open shared object file: No such file or directory'

keenerd commented on 2012-05-24 00:17

In theory, these problems should be fixed by building edelib with --enable-shared.
But that breaks dbus. Add --disable-dbus to it and that breaks a whole bunch of odd things in C++.

I am a little stuck.

Anonymous comment on 2012-05-23 15:54

Hello,
i get this:

ede-panel
[edelib] src/Window.cpp:53: loading 'edeneu' theme
[ede-panel] ede-panel/AppletManager.cpp:49: Unable to load '/usr/share//ede/panel-applets/start_menu.so' : '/usr/share//ede/panel-applets/start_menu.so: cannot open shared object file: No such file or directory'

Alister.Hood commented on 2012-05-23 13:21

I had the same problem with being unable to start it, but somehow the unset solution didn't seem to work. To fix it I also had to remove all the tests like this:

if [ "x$XDG_DATA_HOME" = "x" ]; then

swanson commented on 2012-05-23 04:58

Why is .config/ede/ede-settings.conf always overwritten? /usr/etc/xdg/ede/ede-settings.conf isn't even used.

swanson commented on 2012-05-22 05:24

A quirk; after installing ede 2 the ede-tip autostarts in my openbox-session!? I've search in all autostart files and .Xsession/.xinitrc files , high and low, but can not find where it starts from. Nothing of Ede is running and the autostart box in ede-tip IS unticked. Any ideas?

swanson commented on 2012-05-21 15:24

This could be something! Couldn't start ede but this thread solved that; http://sourceforge.net/projects/ede/forums/forum/249616/topic/5288645
XDG settings was not ok. It seems very responsive but I wich there was some settings gui. I edited some ede-conf files but didn't acheive what I wanted. Looking forward to updates.

keenerd commented on 2012-05-19 16:30

So the pieces work individually, but evoke doesn't start them up properly. Open to suggestions.

keenerd commented on 2012-05-19 16:25

So the pieces work individually, but evoke does start them up properly. Open to suggestions.