Package Details: edi-git f80b901-1

Git Clone URL: https://aur.archlinux.org/edi-git.git (read-only)
Package Base: edi-git
Description: The EFL IDE
Upstream URL: https://phab.enlightenment.org/w/projects/edi/
Keywords: development efl IDE
Licenses: GPL2
Submitter: J5lx
Maintainer: None
Last Packager: J5lx
Votes: 3
Popularity: 0.000005
First Submitted: 2014-11-25 22:13
Last Updated: 2015-07-14 18:18

Latest Comments

jabol240 commented on 2016-01-16 19:10

build fails. efl 1.16.0 here. clang absent, although it doesn't seem to be neccessary (?).

make[4]: Entering directory '/tmp/yaourt-tmp-me/aur-edi-git/src/edi/elm_code/src/lib'
EOLIAN widget/elm_code_widget.eo.c
eolian: --eo not specified
Makefile:971: recipe for target 'widget/elm_code_widget.eo.c' failed
make[4]: *** [widget/elm_code_widget.eo.c] Error 1
make[4]: Leaving directory '/tmp/yaourt-tmp-me/aur-edi-git/src/edi/elm_code/src/lib'
Makefile:391: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/tmp/yaourt-tmp-me/aur-edi-git/src/edi/elm_code/src'
Makefile:391: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp-me/aur-edi-git/src/edi/elm_code'
Makefile:723: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-me/aur-edi-git/src/edi'
Makefile:633: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build edi-git.

any assistance appreciated

J5lx commented on 2015-06-07 13:52

Yeah. When I last built it it worked fine with the latest release though, and since I don't like to force users to install large dependency trees of git packages even though the software they want the bleeding-edge version of might work just fine with the stable release, I didn't put the git versions in depends(). I'll think about it though.

Cravix commented on 2015-06-07 11:15

failed at build time, it told me eina & edje 1.14.99 is needed,
so seems the dependency "efl" should be changed to "efl-git" :P

Cravix commented on 2015-06-07 11:14

failed in build time, it told me eina & edje 1.14.99 is needed,
so seems the dependency "efl" should be changed to "efl-git" :P

J5lx commented on 2015-03-21 08:18

Thanks for reporting! Should be fixed now.

Anonymous comment on 2015-03-20 17:14

Build failed with this error

==> Starting pkgver()...
==> Updated version: edi-git 8bbec0d-1
==> Starting prepare()...
patching file data/extra/Makefile.am
Hunk #1 FAILED at 4.
1 out of 1 hunk FAILED -- saving rejects to file data/extra/Makefile.am.rej
==> ERROR: A failure occurred in prepare().
Aborting...