Package Details: editorconfig-qtcreator 0.3.1+4.12.0-1

Git Clone URL: (read-only, click to copy)
Package Base: editorconfig-qtcreator
Description: EditorConfig Plugin for QtCreator
Upstream URL:
Keywords: broken eol missingdep to-be-deleted unneeded
Licenses: LGPL
Submitter: J5lx
Maintainer: MarsSeed
Last Packager: J5lx
Votes: 1
Popularity: 0.000000
First Submitted: 2017-06-02 11:01 (UTC)
Last Updated: 2020-05-01 13:34 (UTC)

Latest Comments

redtide commented on 2020-01-15 08:23 (UTC)

Just built with 0.3.1, it was fixed.

_pkgver=0.3.1 _qtcreatorver=4.11.0

sha512sums=('53d4f9a875d5aaebd4df0310a4f44a087de8c4f63f5e54387c0e7ea0b5792c455c4b6d41f993b72d23ad5317867b91db5bafc727f6bc9514460f7918ff2c3a2e' 'a0eef2df7ad9ae171facef4ccc08652243153bb0b29b3af531ba2d0bd93a09d043b2e87d79450dedf18c01b57ad5c474a44a942a9e27553211a5722740c840af')

J5lx commented on 2019-12-15 02:13 (UTC)

Note: Version 0.3.0 of this plugin appears to be incompatible with qtcreator 4.11, so I’m currently unable to update this package until someone comes up with a fix.

J5lx commented on 2019-06-11 08:27 (UTC)

Yeah, “shouldn’t”... The thing is, you're supposed to build plugins against the build tree that resulted from your build of Qt Creator, and to me that feels like the creators of Qt Creator are trying to discourage the distribution of 3rd-party plugins. For that reason, I don’t really want to make any blind assumptions about ABI compatibility between versions – especially so since I'm already using some dirty hackery to get around the build tree requirement. Now if Qt Creator made actual guarantees about ABI compatibility or if there was anything that would indicate they at least intend to provide such compatibility, I’d be happy to relax the version requirement. Maybe I can find some time to look for pointers, or maybe you got something to back up your statement – otherwise I’d rather keep the version requirement the way it is, strict though it may be.

dos1 commented on 2019-05-28 12:46 (UTC)

I think the version dependency on qtcreator is a bit too strict. Minor releases of QtCreator shouldn't break plugin ABI, so it's enough to depend on "4.9.x". Now the dependencies are broken on every minor release, so 4.9.1 needs an update even though it's not really necessary.

dos1 commented on 2019-04-22 19:22 (UTC)

does not build with 4.9.0 - needs "KSYNTAXHIGHLIGHTING_LIB_DIR=/usr/lib KSYNTAXHIGHLIGHTING_INCLUDE_DIR=/usr/include/KF5/KSyntaxHighlighting" args added to qmake

J5lx commented on 2018-05-14 17:10 (UTC)

The reason is because the plugin will only work with the version of Qt Creator that it has been compiled against, so when it has been compiled against 4.5.0 that build has a dependency on Qt Creator 4.5.0. That said, updating the Qt Creator version in the PKGBUILD and rebuilding the package should be enough to make it work with any newer version of Qt Creator. So, when there’s a new version of Qt Creator and I haven’t updated this package yet, feel free to do so (but please also flag the package out-of-date so I can push an update for everyone as soon as possible).

Also, sorry for not answering earlier! I thought I had already done so and only now noticed I actually didn’t.

sum01 commented on 2018-03-16 15:30 (UTC) (edited on 2018-03-16 15:32 (UTC) by sum01)

Is there a reason this requires qtcreator v4.5.0? Since I downloaded the newest version from the main repo's I can't use this.

J5lx commented on 2017-12-16 13:21 (UTC)

I’m pretty sure it’s possible, but I don’t think we should do that here. After all, we’re not talking about auto-updating the plugin version, we’re talking about auto-updating the qtcreator version. That means if a qtcreator update breaks the build, it will be potentially hard to debug that. Plus, the builds will generally be less reproducible.

nightuser commented on 2017-12-15 15:20 (UTC)

Is it possible to generate QtCreator prefix dynamically? Similarly to the pkgver() function for VCS packages.