Package Details: edk2-avmf 20220826gitba0e0e4c6a17-1

Git Clone URL: https://aur.archlinux.org/edk2-avmf.git (read-only, click to copy)
Package Base: edk2-avmf
Description: QEMU ARM/AARCH64 Virtual Machine Firmware (Tianocore UEFI firmware).
Upstream URL: https://fedoraproject.org/wiki/Using_UEFI_with_QEMU
Keywords: aarch64 arm avmf edk2 qemu uefi
Licenses: BSD
Submitter: levinit
Maintainer: levinit (robertfoster, simona, stafwag, Solskogen)
Last Packager: levinit
Votes: 10
Popularity: 0.050179
First Submitted: 2019-08-15 13:30 (UTC)
Last Updated: 2022-10-15 12:30 (UTC)

Latest Comments

1 2 3 Next › Last »

dreieck commented on 2022-05-10 13:49 (UTC) (edited on 2022-05-12 11:23 (UTC) by dreieck)

@levinit, you just added me as co maintainer. I am not willing to maintain this package. Please remove my co-maintainership again (I do not find "disown" for the co-maintained package).

dreieck commented on 2022-05-10 08:58 (UTC) (edited on 2022-05-12 11:25 (UTC) by dreieck)

Please add conflicts=('edk2-armvirt'):

(92/92) checking for file conflicts                                                                                    [########################################################################] 100%
error: failed to commit transaction (conflicting files)
edk2-armvirt: /usr/share/AAVMF/AAVMF_CODE.fd exists in filesystem (owned by edk2-avmf)
edk2-armvirt: /usr/share/AAVMF/AAVMF_VARS.fd exists in filesystem (owned by edk2-avmf)

Thanks for maintaining!

byreqz commented on 2022-05-10 06:14 (UTC)

This is now provided by extra/edk2-armvirt since Qemu 7.0:

$ pacman -Ql edk2-armvirt                                                                                                             
edk2-armvirt /usr/
edk2-armvirt /usr/share/
edk2-armvirt /usr/share/AAVMF/
edk2-armvirt /usr/share/AAVMF/AAVMF_CODE.fd
edk2-armvirt /usr/share/AAVMF/AAVMF_VARS.fd
edk2-armvirt /usr/share/edk2-armvirt/
edk2-armvirt /usr/share/edk2-armvirt/aarch64/
edk2-armvirt /usr/share/edk2-armvirt/aarch64/QEMU_CODE.fd
edk2-armvirt /usr/share/edk2-armvirt/aarch64/QEMU_EFI.fd
edk2-armvirt /usr/share/edk2-armvirt/aarch64/QEMU_VARS.fd
edk2-armvirt /usr/share/licenses/
edk2-armvirt /usr/share/licenses/edk2-armvirt/
edk2-armvirt /usr/share/licenses/edk2-armvirt/License.txt
edk2-armvirt /usr/share/qemu/
edk2-armvirt /usr/share/qemu/firmware/
edk2-armvirt /usr/share/qemu/firmware/60-edk2-armvirt-aarch64.json

adam900710 commented on 2022-04-23 09:41 (UTC)

The URL changed again...

Would it be possible to compile the package and then provide a -bin version?

stafwag commented on 2022-04-09 07:01 (UTC)

@dreieck

Thanks for reporting!

I updated it to latest release...

dreieck commented on 2022-03-15 11:21 (UTC)

Source download fails now:

Resolving download-ib01.fedoraproject.org (download-ib01.fedoraproject.org)... 152.19.134.145, 2600:2701:4000:5211:dead:beef:fe:fed6
Connecting to download-ib01.fedoraproject.org (download-ib01.fedoraproject.org)|152.19.134.145|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-03-15 12:21:29 ERROR 404: Not Found.

==> ERROR: Failure while downloading https://download-ib01.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/aarch64/os/Packages/e/edk2-aarch64-20211126gitbb1bba3d7767-2.fc36.noarch.rpm
    Aborting...

Thanks for maintaining!

Solskogen commented on 2022-03-14 13:39 (UTC) (edited on 2022-03-14 13:39 (UTC) by Solskogen)

checksums are bad

diff --git a/PKGBUILD b/PKGBUILD
index 760896d..9f0d931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,8 @@ source=(
   "https://download-ib01.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/aarch64/os/Packages/e/edk2-aarch64-${pkgver}-${pkgrel}.fc${fedora_ver}.noarch.rpm"
   "https://download-ib01.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/aarch64/os/Packages/e/edk2-arm-${pkgver}-${pkgrel}.fc${fedora_ver}.noarch.rpm")

-sha256sums=('e50e0621bf93363bcd125cda86b56b2f5c082eff82d856b0ba7948da1b9422ac'
-            '030e759fbd2491fb27e15cbf505b4860828ac41065db0e3da1acdf23901042db')
+sha256sums=('74ba5ed283fde7ae8633e90cd09c59ad79fbd3e57f66ccb7b63bf827d5cf072c'
+            'bfc2d3efe7eec42b2434544e0eda1a1b4e0cd5e60fc76f0c7adf2c227edb074e')

 install=${pkgname}.install

vauntedvulture38 commented on 2021-12-13 14:25 (UTC) (edited on 2021-12-13 14:26 (UTC) by vauntedvulture38)

pkgver=20211126gitbb1bba3d7767 pkgrel=1

these are working now

scrouthtv commented on 2021-10-13 17:30 (UTC)

The install file is missing a separator causing libvirtd to crash.