Package Details: ee-editor 1.5.2-4

Git Clone URL: https://aur.archlinux.org/ee-editor.git (read-only, click to copy)
Package Base: ee-editor
Description: EasyEdit, a classic curses text editor. Born in HP-UX, used in FreeBSD.
Upstream URL: http://www.users.qwest.net/~hmahon/
Licenses: BSD
Submitter: vorbote
Maintainer: aksr
Last Packager: aksr
Votes: 23
Popularity: 0.000000
First Submitted: 2014-04-15 21:28
Last Updated: 2020-01-06 05:23

Latest Comments

kindusmith commented on 2019-12-30 01:44

This source code does need some modification, otherwise an error will be reported. Please modify line 555 of src / easyedit-1.5.2 / ee.c in your clone directory to modify it to: "For (counter = 1; counter <24; counter ++)" Then execute make and make install in this directory and you can use it.

jethrogb commented on 2016-07-06 02:11

As anonymous points out, the default build does not link against the system-provided ncurses. To fix, just replace the lines with create.make and make in the build() function in PKGBUILD by:

gcc -o ee -DHAS_UNISTD -DHAS_STDLIB -DHAS_CTYPE -DHAS_SYS_IOCTL -DHAS_SYS_WAIT -DSLCT_HDR ee.c -lcurses

Anonymous comment on 2010-11-11 23:12

This uses the original Makefile, which doesn't give very good results on any linux system I've tried (spurious border characters and occasional glitches). Suggest changing to something more like the old Debian Makefile, which uses the distro ncurses instead. I've created a pastebin of a working Makefile (without comments). Give it a shot and see what think:

http://aur.pastebin.com/download.php?i=VzEcJEhc