Package Details: eid-viewer 4.1.20-1

Git Clone URL: https://aur.archlinux.org/eid-viewer.git (read-only)
Package Base: eid-viewer
Description: eID-Viewer is a graphical interface to the Belgian Electronic Identity Card
Upstream URL: http://eid.belgium.be/
Licenses: LGPL3
Submitter: vlc
Maintainer: wget
Last Packager: wget
Votes: 28
Popularity: 1.897048
First Submitted: 2011-10-29 10:48
Last Updated: 2017-01-08 18:17

Pinned Comments

wget commented on 2017-01-10 21:06

Hello there. I'm the new maintainer. I know this package has sources which are not from the release server, but rather the continuous integration server. I'll continue with that branch as the release server has no https for now. I'll switch to the release branch as soon we have https on the server.

Latest Comments

wget commented on 2017-01-11 11:36

Switching to the release server will be sooner than anticipated. https://twitter.com/wouter_verhelst/status/819143456647970816

wget commented on 2017-01-10 21:06

Hello there. I'm the new maintainer. I know this package has sources which are not from the release server, but rather the continuous integration server. I'll continue with that branch as the release server has no https for now. I'll switch to the release branch as soon we have https on the server.

wget commented on 2017-01-10 21:04

@olive As precised on eid-mw, we will still use the dist branch for now, as the official branch has still no https. As soon the official branch switches to https, I'll change the URL and GPG signatures accordingly.

olive commented on 2017-01-08 20:25

I think it's better to take the official version as recommended on the official eid website. This is the usual policy for official Arch package. Especially for this package where there is no conceivable benefit to using a development version (the purpose is to be able to authenticate, nothing more). and which deal with security.

wget commented on 2017-01-08 18:19

Hello there. I'm the new maintainer. Have just updated the package to 4.1.20 and am checking GPG signatures and SHA512 digests from now on.

I have just realized the sources we are using come from the dist server which is a continuous environment server. Maybe we should be using the official releases from http://eid.belgium.be/en/using_your_eid/installing_the_eid_software/linux? Let me know what you think about this? Leave it as it or change the branch?

plenaerts commented on 2016-06-18 07:03

Updating to 4.1.18 works.

Git diff: http://pastebin.com/BGbQJpu4

Alad commented on 2015-08-09 00:05

Updated

Alad commented on 2014-11-30 11:59

Sorry, rushed upload. Fixed.

acaccia commented on 2014-11-30 11:46

please change lines 17 and 22:
$pkgver -> ${pkgver%_*}

noplomplom commented on 2014-11-30 07:26

Build error with PKGBUILD 4.0.7_195-1: "line 22: cd: ${srcdir}/eid-viewer-4.0.7_195: No such file or directory".
To build the package, it is necessary to change the extracted folder name "eid-viewer-4.0.7" to "eid-viewer-4.0.7_195" under src directory.

eMerzh commented on 2014-11-12 11:00

had to install eid-mw and ccid but now it seems to work (the viewer at least)

Alad commented on 2014-08-29 18:18

Works for me

zumanji commented on 2014-07-07 20:30

I tried to build latest version but no luck so far. Output log: http://pastebin.com/h9ULsbWM

olive commented on 2014-06-29 06:51

Upstream sources have been updated and PKGBUILD file point to a file that does not exist anymore (and is available nowhere on the web). The upstream current version (4.0.7) crash with jre7-openjdk but work with the proprietary jre7 available on the AUR.

olive commented on 2014-06-29 06:42

Upstream sources have been updated and PKGBUILD file point to a file that does not exist anymore (and is available nowhere on the web). The upstream current version (4.0.7) crash in my system (64 bit archlinux) (sigsev); I have not found a solution so far.

olive commented on 2013-02-07 17:52

The software works fine but it requires gsettings-desktop-schemas. Otherwise it crashes with:
(process:827): GLib-GIO-ERROR **: Settings schema 'org.gnome.system.proxy' is not installed

Maybe that could be added in the depends.

valr commented on 2012-07-01 14:52

PKGBUILDs using the http://eid.belgium.be official website:
- middleware: http://pastebin.archlinux.fr/448649
- viewer: http://pastebin.archlinux.fr/448650

gatchan commented on 2012-04-18 05:35

disponible sur le site: http://eid.belgium.be/fr/utiliser_votre_eid/installer_le_logiciel_eid/linux/

http://eid-mw.googlecode.com/files/eid-mw-4.0.2-1188.tar.gz
et
http://eidfiles.be/continuous/viewer/eid-viewer-4.0.2-132.jar