Package Details: electorrent 2.7.2-1

Git Clone URL: https://aur.archlinux.org/electorrent.git (read-only, click to copy)
Package Base: electorrent
Description: A remote control client for µTorrent, qBittorrent, rTorrent, Transmission, Synology & Deluge
Upstream URL: https://github.com/Tympanix/Electorrent
Keywords: bittorrent-client magnet-link qbittorrent remote-control rtorrent torrent torrent-files torrent-management transmission utorrent
Licenses: GPL3
Submitter: ragouel
Maintainer: joaquinito2051
Last Packager: ragouel
Votes: 0
Popularity: 0.000000
First Submitted: 2020-11-28 22:31
Last Updated: 2020-12-26 01:03

Latest Comments

Akuruma commented on 2021-05-07 18:14

missing python2 in dependencies?

Preparing...
Cloning electorrent build files...
Checking electorrent dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building electorrent...
==> Making package: electorrent 2.7.2-1 (Fr 07 Mai 2021 20:09:55)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found electorrent-2.7.2.tar.gz
==> Validating source files with sha256sums...
    electorrent-2.7.2.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting electorrent-2.7.2.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
npm notice 
npm notice New minor version of npm available! 7.11.2 -> 7.12.0
npm notice Changelog: <https://github.com/npm/cli/releases/tag/v7.12.0>
npm notice Run `npm install -g npm@7.12.0` to update!
npm notice 
npm ERR! code 127
npm ERR! path /var/tmp/pamac-build-akuruma/electorrent/src/Electorrent-2.7.2/node_modules/fibers
npm ERR! command failed
npm ERR! command sh -c node build.js || nodejs build.js
npm ERR! gyp info it worked if it ends with ok
npm ERR! gyp info using node-gyp@4.0.0
npm ERR! gyp info using node@16.0.0 | linux | x64
npm ERR! gyp ERR! configure error 
npm ERR! gyp ERR! stack Error: Python executable "/usr/bin/python" is v3.9.4, which is not supported by gyp.
npm ERR! gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
npm ERR! gyp ERR! stack     at PythonFinder.failPythonVersion (/var/tmp/pamac-build-akuruma/electorrent/src/Electorrent-2.7.2/node_modules/node-gyp/lib/configure.js:493:19)
npm ERR! gyp ERR! stack     at PythonFinder.<anonymous> (/var/tmp/pamac-build-akuruma/electorrent/src/Electorrent-2.7.2/node_modules/node-gyp/lib/configure.js:475:14)
npm ERR! gyp ERR! stack     at ChildProcess.exithandler (node:child_process:317:7)
npm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:365:28)
npm ERR! gyp ERR! stack     at maybeClose (node:internal/child_process:1067:16)
npm ERR! gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)
npm ERR! gyp ERR! System Linux 5.12.1-2-MANJARO
npm ERR! gyp ERR! command "/usr/bin/node" "/var/tmp/pamac-build-akuruma/electorrent/src/Electorrent-2.7.2/node_modules/.bin/node-gyp" "rebuild" "--release"
npm ERR! gyp ERR! cwd /var/tmp/pamac-build-akuruma/electorrent/src/Electorrent-2.7.2/node_modules/fibers
npm ERR! gyp ERR! node -v v16.0.0
npm ERR! gyp ERR! node-gyp -v v4.0.0
npm ERR! gyp ERR! not ok 
npm ERR! node-gyp exited with code: 1
npm ERR! Please make sure you are using a supported platform and node version. If you
npm ERR! would like to compile fibers on this machine please make sure you have setup your
npm ERR! build environment--
npm ERR! Windows + OS X instructions here: https://github.com/nodejs/node-gyp
npm ERR! Ubuntu users please run: `sudo apt-get install g++ build-essential`
npm ERR! RHEL users please run: `yum install gcc-c++` and `yum groupinstall 'Development Tools'` 
npm ERR! Alpine users please run: `sudo apk add python make g++`
npm ERR! sh: line 1: nodejs: command not found

npm ERR! A complete log of this run can be found in:
npm ERR!     /var/tmp/pamac-build-akuruma/electorrent/src/npm-cache/_logs/2021-05-07T18_10_06_834Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...

after installing Python2 it installs normally

ragouel commented on 2020-11-30 22:57

You're right. I fixed it.

yochananmarqos commented on 2020-11-29 16:06

This needs to build from source. Binary packages need to be submitted with a -bin extension; i.e. electorrent-bin.