Package Details: electron-cash 3.3.4-1

Git Clone URL: (read-only)
Package Base: electron-cash
Description: Lightweight Bitcoin Cash wallet
Upstream URL:
Licenses: MIT
Conflicts: electron-cash
Provides: electron-cash
Submitter: devopsdeluxe
Maintainer: marceloneil
Last Packager: marceloneil
Votes: 20
Popularity: 0.699575
First Submitted: 2017-08-18 15:38
Last Updated: 2018-12-30 06:22

Dependencies (27)

Required by (0)

Sources (1)

Latest Comments

1 2 3 Next › Last »

ciupenhauer commented on 2018-12-03 21:12

@marceloneil yeah, thanks. I was having a virtual environment activated

marceloneil commented on 2018-11-24 20:59

@ciupenhauer I'm not sure. I cannot reproduce this issue. Are you fully up to date and using python3.7?

ciupenhauer commented on 2018-11-23 12:14

==> Starting build()... File "contrib/make_locale", line 54 print("", "update-file:", "-"20, response.text, "-"20, sep="\n") ^ SyntaxError: invalid syntax

Any ideas what this is about?

z3ntu commented on 2018-11-13 16:19

The install script can be removed as it's (for a few years already) replaced by pacman hooks.

marceloneil commented on 2018-10-17 23:29

Thanks @rgeorgy. Electron Cash recently relocated from to This caused the folder name in the generated tarball to change, altering the hash.

rgeorgy commented on 2018-10-17 01:44

Validating source files fails:

==> Making package: electron-cash 3.3.1-2 (Tue 16 Oct 2018 09:38:25 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found electron-cash-3.3.1.tar.gz
  -> Found electron-cash.install
==> Validating source files with sha256sums...
    electron-cash-3.3.1.tar.gz ... FAILED
    electron-cash.install ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build electron-cash.

marceloneil commented on 2018-08-06 21:53

Thanks @dangersalad

dangersalad commented on 2018-08-06 21:29

Needs an update to work with python 3.7

I just changed the py36 to py37 in the check() function and it reinstalled fine.

ivan.masich commented on 2018-07-28 18:21

@marceloneil thanks for help, I'm not sure why I got this problem, but removing this module from global scope and then installing it as user module solved the issue.

sudo pip3 uninstall PyQt5_sip
pip3 install --user PyQt5_sip

marceloneil commented on 2018-07-25 20:10

@ivan.masich It seems like the package is being built using your local python modules .local/lib/python, rather than /usr/lib/python. This PKGBUILD requires python-pyqt5, which requires python-sip-pyqt5. So if you built the app using your system python modules it would work fine, or install to your local python modules.