Package Details: electron-cash 4.0.7-2

Git Clone URL: (read-only)
Package Base: electron-cash
Description: Lightweight Bitcoin Cash wallet
Upstream URL:
Licenses: MIT
Conflicts: electron-cash
Provides: electron-cash
Submitter: devopsdeluxe
Maintainer: marceloneil (0e4ef622)
Last Packager: 0e4ef622
Votes: 23
Popularity: 1.410272
First Submitted: 2017-08-18 15:38
Last Updated: 2019-06-25 03:57

Dependencies (27)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

z3ntu commented on 2018-11-13 16:19

The install script can be removed as it's (for a few years already) replaced by pacman hooks.

marceloneil commented on 2018-10-17 23:29

Thanks @rgeorgy. Electron Cash recently relocated from to This caused the folder name in the generated tarball to change, altering the hash.

rgeorgy commented on 2018-10-17 01:44

Validating source files fails:

==> Making package: electron-cash 3.3.1-2 (Tue 16 Oct 2018 09:38:25 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found electron-cash-3.3.1.tar.gz
  -> Found electron-cash.install
==> Validating source files with sha256sums...
    electron-cash-3.3.1.tar.gz ... FAILED
    electron-cash.install ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build electron-cash.

marceloneil commented on 2018-08-06 21:53

Thanks @dangersalad

dangersalad commented on 2018-08-06 21:29

Needs an update to work with python 3.7

I just changed the py36 to py37 in the check() function and it reinstalled fine.

ivan.masich commented on 2018-07-28 18:21

@marceloneil thanks for help, I'm not sure why I got this problem, but removing this module from global scope and then installing it as user module solved the issue.

sudo pip3 uninstall PyQt5_sip
pip3 install --user PyQt5_sip

marceloneil commented on 2018-07-25 20:10

@ivan.masich It seems like the package is being built using your local python modules .local/lib/python, rather than /usr/lib/python. This PKGBUILD requires python-pyqt5, which requires python-sip-pyqt5. So if you built the app using your system python modules it would work fine, or install to your local python modules.

ivan.masich commented on 2018-07-24 13:23

I found problem during upgrading package to newer version uisng aurman, can you please help me, here is output of the error:

==> Starting build()...
Traceback (most recent call last):
  File "/usr/lib/python3.6/", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib/python3.6/", line 85, in _run_code
    exec(code, run_globals)
  File "/home/ivan-masich/.local/lib/python3.6/site-packages/PyQt5/", line 21, in <module>
    from PyQt5.QtCore import PYQT_VERSION_STR, QDir, QFile
ModuleNotFoundError: No module named 'PyQt5.sip'
==> ERROR: A failure occurred in build().
2018-07-24 16:19:19,080 - wrappers - makepkg - ERROR - makepkg query ['makepkg', '-cf', '--noconfirm'] failed in directory /home/ivan-masich/.cache/aurman/electron-cash

marceloneil commented on 2018-04-25 19:23

@eomanis No problem! I was already working on a fix when you commented.

eomanis commented on 2018-04-25 19:22

@marceloneil It works correctly now. Well that was quick, thanks