Package Details: electron-ssr 0.2.6-5

Git Clone URL: https://aur.archlinux.org/electron-ssr.git (read-only)
Package Base: electron-ssr
Description: Shadowsocksr client using electron.
Upstream URL: https://github.com/erguotou520/electron-ssr
Keywords: electron shadowsocksr ssr
Licenses: MIT
Conflicts: electron-ssr-git
Provides: electron-ssr
Submitter: axionl
Maintainer: bruceutut
Last Packager: bruceutut
Votes: 4
Popularity: 0.230041
First Submitted: 2018-05-27 12:15
Last Updated: 2019-04-12 07:09

Pinned Comments

bruceutut commented on 2019-01-21 03:29

0.2.6-4 合并所有 patch 并添加 patch 兼容 electron 4.x


Electron SSR 0.2.5 版本已提交
添加 build.patch 以使用官方 electron 包打开应用,添加 argv.patch 以支持直接点击 ssr/ss 链接添加配置,改用官方仓库内的应用图标

部分桌面环境可能无法支持点击 ss/ssr 链接添加配置,因为较长链接会被解析丢失冒号 目前没有什么办法。

Latest Comments

1 2 Next › Last »

bruceutut commented on 2019-04-13 08:02

@huyizheng

第一个问题我这边没有发现,可能是 Electron 4.x 有一些变动;
第二个问题暂时无法处理,建议从应用程序菜单拖动固定到任务栏。

huyizheng commented on 2019-04-13 03:27

更新最新版之后发现一个(应该是)bug(但不影响使用): 打开electron-ssr的界面,上面出现了electron自带的菜单栏。之间electron3版本时没有这个问题。 另外还有一个存在了一段时间的小问题,就是当打开界面后,在kde任务栏上将其固定,则之后从任务栏上的图标打开的是electron应用而非electron-ssr。

huyizheng commented on 2019-01-22 08:29

更新到0.2.5-5之后配置文件路径正常。

还有一个小问题(这个问题不影响软件的使用),主界面标题栏上显示“electron-ssr v3.1.1”,即版本号显示成了系统electron的版本3.3.1而不是electron-ssr的版本0.2.5。

bruceutut commented on 2019-01-21 14:41

@huyizheng 尝试更新到 0.2.5-5

huyizheng commented on 2019-01-21 13:06

最新版安装好之后发现它把配置文件存在了$HOME/.config/Electron目录下了,0.2.4版是存在$HOME/.config/electron-ssr目录下的。

bruceutut commented on 2019-01-21 03:29

0.2.6-4 合并所有 patch 并添加 patch 兼容 electron 4.x


Electron SSR 0.2.5 版本已提交
添加 build.patch 以使用官方 electron 包打开应用,添加 argv.patch 以支持直接点击 ssr/ss 链接添加配置,改用官方仓库内的应用图标

部分桌面环境可能无法支持点击 ss/ssr 链接添加配置,因为较长链接会被解析丢失冒号 目前没有什么办法。

axionl commented on 2018-07-29 07:27

@FFY00 Thanks for your checking, I originally wanted to fix these problems. But after reading the source code, I want to remove this package.

FFY00 commented on 2018-07-28 14:01

Please rename to source to a unique name so that it doesn't conflict when building in a dirty directory. Apply patches in prepare() not build().

EDIT: Sorry about that, yarn is building from a tarball here. Its beavior is the same as NPM. The build commands are fine. I was under the impression that it still downloaded dependencies on it's own and I wasn't around a computer where I could test that. Learned the lesson, next time don't comment without testing :/

Yinr commented on 2018-04-26 10:59

need gconf as a dependency under 4.16.3-1-ARCH & Gnome 3.28.1

unstartdev commented on 2018-02-21 13:33

脑抽,忘了