Package Details: elvis 2.2_0-4

Git Clone URL: https://aur.archlinux.org/elvis.git (read-only)
Package Base: elvis
Description: A vi clone with optional X support. Stable or beta version.
Upstream URL: http://elvis.the-little-red-haired-girl.org/
Licenses: PerlArtistic
Replaces: elvis_patched-withx, elvis_slack
Submitter: billycongo
Maintainer: keenerd
Last Packager: keenerd
Votes: 4
Popularity: 0.000048
First Submitted: 2005-10-16 02:39
Last Updated: 2016-05-06 12:00

Latest Comments

mitsunari commented on 2016-05-01 12:55

Hi,

the netbsd patches have changed, the current version works but the checksum has changed. this patch fixes the build:

[EDIT: inline formatting is horrible, I uploaded the patch here https://gist.github.com/Sanada-Mitsunari/6dd7f4ea5a11077cc883b8555da9ef1a but it's really just re-calculated md5sums]

diff --git a/PKGBUILD b/PKGBUILD
index 2d4bacc..6a0a683 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _SLACKWARECOLORS=false # elvis colorscheme from slackware not installed by defa

pkgname=elvis
pkgver=2.2_0
-pkgrel=3
+pkgrel=4
url="http://elvis.the-little-red-haired-girl.org/"
#url="http://elvis.vi-editor.org/"
pkgdesc="A vi clone with optional X support. Stable or beta version."
@@ -29,8 +29,8 @@ source=("http://www.the-little-red-haired-girl.org/pub/elvis/elvis-${pkgver}.tar
"http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/pkgsrc/editors/elvis/patches/patch-ae"
"ftp://ftp.slackware.com/pub/slackware/slackware-13.0/source/a/elvis/elvis.clr")
md5sums=('6831b8df3e4a530395e66c2889783752'
- '8d9df9aa5edcf8e0b8a2f5d59d1c30c7'
- '2bec41d9f09542e2ef41de1e6b41727e'
+ '106a047c6256695f874a1e4ac16386a9'
+ 'd993e8367da29268547d071dfc4d43b9'
'c47a70cb176ebf2eb99b055c4048a560')

_DESKTOPFILE="[Desktop Entry]\\nType=Application\\nVersion=1.0\\nName=Elvis\\nComment=A simple text editor\\nExec=elvis\\nIcon=$pkgname\\nTerminal=true\\nCategories=Editors;Programming;Accessories"

jangler commented on 2015-05-15 03:03

curl: (9) Server denied you to change to the given directory
==> ERROR: Failure while downloading elvis-2.2_0.tar.gz

haawda commented on 2010-04-28 18:26

I think, these two AUR packages should be merged.

Anonymous comment on 2010-04-28 16:35

This one should work:

http://aur.archlinux.org/packages.php?ID=33899

Anonymous comment on 2010-04-27 05:52

gcc -O2 -Iosunix main.o osblock.o osdir.o osprg.o ostext.o osnet.o optglob.o options.o safe.o session.o buffer.o calc.o color.o descr.o digraph.o display.o gui.o lowbuf.o mark.o misc.o io.o dmhex.o dmmarkup.o dmnormal.o dmsyntax.o scan.o tcaphelp.o autocmd.o cut.o draw.o event.o ex.o exaction.o exconfig.o exedit.o exmake.o exsubst.o fold.o ftp.o http.o input.o lp.o map.o message.o move.o more.o need.o operator.o regexp.o region.o regsub.o search.o spell.o state.o tinytcap.o tag.o tagsrch.o tagelvis.o url.o vi.o vicmd.o window.o guix11.o xclip.o xevent.o xmisc.o xscroll.o xstatus.o xtext.o xtool.o xdialog.o guicurs.o guitcap.o guiopen.o lpescape.o lpovrtyp.o lpps.o -lX11 -lncurses -lresolv -o elvis
gcc -O2 -Iosunix -c -o ref.o ref.c
ref.c:45:14: error: conflicting types for ‘getline’
/usr/include/stdio.h:651:20: note: previous declaration of ‘getline’ was here
make: *** [ref.o] Error 1
==> ERROR: Build Failed.
Aborting...
Error: Makepkg was unable to build elvis package.