Package Details: emacs-24bit 25.1-2

Git Clone URL: https://aur.archlinux.org/emacs-24bit.git (read-only)
Package Base: emacs-24bit
Description: The extensible, customizable, self-documenting real-time display editor
Upstream URL: http://www.gnu.org/software/emacs/emacs.html
Licenses: GPL3
Conflicts: emacs, emacs-nox
Provides: emacs=25.1
Submitter: chopps
Maintainer: chopps
Last Packager: chopps
Votes: 3
Popularity: 0.002723
First Submitted: 2016-01-12 12:16
Last Updated: 2017-03-14 10:26

Required by (273)

Sources (3)

Latest Comments

chopps commented on 2017-03-14 08:09

@hemite I checked out that patch (almost the same as mine) and added the thing I was missing. This worked so I've update this pkg to 25.1 now. Thanks.

hemite commented on 2017-02-18 19:13

@chopps, I was using gnome-terminal, and indeed list-display-colors showed the same output as in X mode

BTW, as of several hours ago, commit e463e5762bbe628be3d15da066a90f079a8468b3 in the emacs master branch enables truecolor in terminal mode.

It can be invoked with TERM=xterm-24bit emacs -nw

chopps commented on 2017-02-07 09:18

@hemite what terminal are you using, are you sure it displayed 24 bit color? Best way to check is `list-display-colors` and make sure everything looks right.

hemite commented on 2017-02-07 07:43

This patch worked for me on emacs 25.x

https://gist.github.com/mhartington/87fe77219c40be845901e496acb82fa3

hemite commented on 2017-02-05 07:37

This patch is pretty fantastic. For those downgrading from extra/emacs, remember to recompile all your installed packages.

chopps commented on 2016-12-21 22:10

I've updated the package with the gmalloc fix and new SRCINFO hopefully this addresses both issues. I don't have the 24bit color fix working with 25.1 yet so for now I'll leave this at 24.5. I did not replicate the pgp or reversed patch issue, but the new SRCINFO added validpgpkey entries that may take care of that.

jgalar commented on 2016-12-21 17:40

makepkg fails with:
==> Verifying source file signatures with gpg...
emacs-24.5.tar.xz ... FAILED (error during signature verification)
==> ERROR: One or more PGP signatures could not be verified!

Moreover, skipping the check results in:
==> Extracting sources...
-> Extracting emacs-24.5.tar.xz with bsdtar
==> Starting prepare()...
patching file lisp/epg.el
Reversed (or previously applied) patch detected! Assume -R? [n]
Apply anyway? [n]

Alad commented on 2016-09-10 22:52

Please apply this patch to avoid build failure:

https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=833727;filename=0020-Always-define-gmalloc-etc.-in-src-gmalloc.c.patch;msg=5

See: https://bugs.archlinux.org/task/50733