Package Details: emacs-async-git v1.9.4.r33.g9a8cd0c-1

Git Clone URL: https://aur.archlinux.org/emacs-async-git.git (read-only, click to copy)
Package Base: emacs-async-git
Description: Asynchronous processing in Emacs
Upstream URL: https://github.com/jwiegley/emacs-async
Licenses: GPL3
Conflicts: emacs-async
Provides: emacs-async
Submitter: sballert
Maintainer: hamki
Last Packager: hamki
Votes: 1
Popularity: 0.010465
First Submitted: 2018-09-13 12:59
Last Updated: 2021-06-18 10:24

Latest Comments

aleksander0m commented on 2021-05-22 19:50

I could make this work with the following hacky patch:

$ git diff
diff --git a/PKGBUILD b/PKGBUILD
index cc9a6d2..d527928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
 _gituser="jwiegley"
 _gitrepo="emacs-async"

-pkgname=emacs-async-git
+pkgname=emacs-async
 _pkgname=async
-pkgver=v1.9.3.r12.g81dc034
+pkgver=1.9.4.r33.g9a8cd0c
 pkgrel=1
 pkgdesc="Asynchronous processing in Emacs"
 url="https://github.com/${_gituser}/${_gitrepo}"
@@ -22,7 +22,7 @@ sha256sums=('SKIP')
 pkgver() {
   cd "$_gitrepo"
   ( set -o pipefail
-  git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+  git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/v1./1./g' ||
   printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

aleksander0m commented on 2021-05-22 19:36

For some reason, this package doesn't satisfy the "emacs-async>=1.9.2" dependency of other packages. Is it because the reported package version starts with "v"?

resolving dependencies...
warning: cannot resolve "emacs-async>=1.9.2", a dependency of "emacs-magit-popup"
warning: cannot resolve "emacs-magit-popup>=2.12.4", a dependency of "emacs-magit"
warning: cannot resolve "emacs-async>=1.9", a dependency of "emacs-with-editor"
warning: cannot resolve "emacs-with-editor>=2.8.0", a dependency of "emacs-magit"
warning: cannot resolve "emacs-ghub>=3.0.0", a dependency of "emacs-magit"
warning: cannot resolve "emacs-async>=1.9.2", a dependency of "emacs-magit-popup"
warning: cannot resolve "emacs-async>=1.9", a dependency of "emacs-with-editor"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      emacs-magit  emacs-magit-popup  emacs-with-editor

:: Do you want to skip the above packages for this upgrade? [y/N] ^C
Interrupt signal received

aleksander@hestia:~$ pacman -Q | grep emacs
emacs 27.2-1
emacs-async v1.9.4.r33.g9a8cd0c-1
emacs-dash 2.18.1-2