Package Details: emacs-editorconfig-git 0.8.2.r4.1d4acc3ec736-1

Git Clone URL: https://aur.archlinux.org/emacs-editorconfig-git.git (read-only, click to copy)
Package Base: emacs-editorconfig-git
Description: EditorConfig Emacs Plugin
Upstream URL: http://github.com/editorconfig/editorconfig-emacs
Licenses: GPL3
Provides: emacs-editorconfig
Submitter: esben
Maintainer: esben
Last Packager: esben
Votes: 3
Popularity: 0.001282
First Submitted: 2016-06-15 09:32 (UTC)
Last Updated: 2022-03-25 06:43 (UTC)

Latest Comments

esben commented on 2022-03-25 06:43 (UTC)

Thanks, should be fixed now.

bobsaintcool commented on 2022-03-13 13:45 (UTC)

Hello @esben thanks for contributing to this package,

It seems that the make target all does not exists anymore thus I got the following error while building the package:

$ aur sync -cd  aur emacs-editorconfig-git
==> Starting build()...
make: *** No rule to make target 'all'.  Stop.
==> ERROR: A failure occurred in build().
    Aborting...

I believe compile is the right target now https://github.com/editorconfig/editorconfig-emacs/blob/1d4acc3ec73609990eabacb59c038708bc401003/Makefile#L27

I offer the following patch

diff --git a/PKGBUILD b/PKGBUILD
index efc1f0b..d868dfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer:  Esben Haabendal <esben@haabendal.dk>

 pkgname=emacs-editorconfig-git
-pkgver=0.8.1.r4.59c734af576b
+pkgver=0.8.2.r4.1d4acc3
 pkgrel=1
 pkgdesc="EditorConfig Emacs Plugin"
 arch=('any')
@@ -24,7 +24,7 @@ pkgver() {
 build() {
   cd "$_github_repo"
   make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}" \
-       all
+       compile
 }

 package() {