Package Details: emacs-lyqi-mode-git r78.4876a0f-2

Git Clone URL: https://aur.archlinux.org/emacs-lyqi-mode-git.git (read-only)
Package Base: emacs-lyqi-mode-git
Description: Emacs mode for LilyPond editing.
Upstream URL: https://github.com/nsceaux/nenuvar
Licenses: GPLv3
Conflicts: emacs-lyqi-mode
Submitter: aksr
Maintainer: aksr
Last Packager: aksr
Votes: 3
Popularity: 0.005375
First Submitted: 2014-05-19 06:16
Last Updated: 2016-04-14 14:33

Latest Comments

Buridan commented on 2016-03-14 19:53

You forgot wget, it's a dependency.

aksr commented on 2016-01-02 12:06

luolimao: Thanks, updated.

luolimao commented on 2015-12-30 22:28

There's an issue with your install file; the code you have right now shows up like this in the console after installation (due to incorrect use of echo):

==> Change your .emacs to make use of lyqi:
;; load lyqi
(load /path/to/lyqi) ;; path to lyqi.elc file, without .elc extension
;; automatically use lyqi mode when editing .ly and .ily files
(add-to-list 'auto-mode-alist '(\.ly . lyqi-mode))
(add-to-list 'auto-mode-alist '(\.ily . lyqi-mode))

I have uploaded a functional version here: https://gist.github.com/luolimao/400027009acc9de8aa31
Note that the backslashes themselves still need to be escaped. Also, you don't need to use (load "/path/to/lyqi"), simply (require 'lyqi) is enough, since the install location is on the emacs load-path.

Finally, makedepends=(wget) needs to be added to the PKGBUILD for it to build (wget isn't part of [base] or [base-devel]), and you can remove all the lines containing blank variables.

aksr commented on 2015-04-29 06:59

Updated.