Package Details: emacs-po-mode 0.19.5-1

Git Clone URL: https://aur.archlinux.org/emacs-po-mode.git (read-only)
Package Base: emacs-po-mode
Description: Emacs po-mode for editing gettext .po files (gettext-tools)
Upstream URL: http://www.gnu.org/software/gettext/
Licenses: GPL
Submitter: ponsfoot
Maintainer: ponsfoot
Last Packager: ponsfoot
Votes: 7
Popularity: 0.000009
First Submitted: 2011-03-13 09:27
Last Updated: 2015-09-07 10:31

Latest Comments

msx commented on 2013-03-24 00:28

New checksum: e6c784c2e7918e34bc3a47ea82a01e7d

ponsfoot commented on 2012-11-24 10:51

@mbunkus: Fixed in 0.18.1.1-5. Thank you for pointing that out.

mbunkus commented on 2012-11-24 09:54

The installation instructions shown after the package has been installed are wrong. In both of the strings listing the .po file names (setq auto-mode-alist, modify-coding-system-alist) the number of backslashes is one too few.

At the moment the output presented to the user looks like this:

(setq auto-mode-alist (cons '("\.po\'\|\.po\." . po-mode)
auto-mode-alist))
(modify-coding-system-alist 'file "\.po\'\|\.po\."
'po-find-file-coding-system)

While it must look like this:

(setq auto-mode-alist (cons '("\\.po\\'\\|\\.po\\." . po-mode)
auto-mode-alist))
(modify-coding-system-alist 'file "\\.po\\'\\|\\.po\\."
'po-find-file-coding-system)

From looking at po-mode.el I guess that you just copy&pasted those instructions from po-mode.el (where they're correct) to your script not taking into account that the shell will remove one layer of escaping before outputting the strings. Emacs does as well, that's why you need two backslashes: the first to tell the interpreter to take the next \ literally, and the second so that the regex engine really sees "\|" instead of "|".

ponsfoot commented on 2012-02-27 12:23

@Mo0O:
Fixed in 0.18.1.1-4. Thank you for your report.

Mo0O commented on 2012-02-26 21:31

add this before in your .emacs

(load-library "po-compat.el") ;; maybe update your .install

or you will have the following error in emacs when opening .po file:
Autoloading failed to define function po-find-file-coding-system

M-x po-mode to enable
on my computer emacs doesn't auto-load po-mode when opening .po file