Package Details: emacs-with-editor 3.0.4-1

Git Clone URL: (read-only, click to copy)
Package Base: emacs-with-editor
Description: Use the Emacsclient as the vim of child processes
Upstream URL:
Licenses: GPL3
Conflicts: emacs-with-editor-git
Provides: emacs-with-editor
Submitter: esben
Maintainer: None
Last Packager: hamki
Votes: 1
Popularity: 0.000000
First Submitted: 2018-06-07 11:53 (UTC)
Last Updated: 2021-06-18 17:29 (UTC)

Latest Comments

esben commented on 2022-03-25 07:23 (UTC)

Please update to latest version. Version >=3.0.5 is needed by magit 3.3.0.

esben commented on 2019-11-04 06:38 (UTC)

Ok, so basically we cannot have versioned dependencies (against emacs). Kind of surprising given the PKGBUILD syntax. Anyway, I will remove it here and in other emacs related packages I maintain.

yar commented on 2019-11-03 23:09 (UTC)

Please remove the versioned emacs dependency by replacing 'emacs>=24.4' with just 'emacs'. It breaks emacs-nox, and the bug was closed as "Won't Implement":

esben commented on 2019-11-02 10:48 (UTC)

Thanks. I have added git to makedepends.

smp commented on 2019-11-02 09:23 (UTC)

The way this PKGBUILD downloads the latest version of emacs-with-editor (using git+https) requires adding git to makedepends. Individual versions of emacs-with-editor can also be downloaded without relying on git from links like <>.