Package Details: emane 0.9.2_r1-1

Git Clone URL: (read-only)
Package Base: emane
Description: Extendable Mobile Ad-hoc Network Emulator
Upstream URL:
Keywords: emulators
Licenses: BSD
Submitter: tom5760
Maintainer: tom5760
Last Packager: tom5760
Votes: 0
Popularity: 0.000000
First Submitted: 2010-10-27 21:22
Last Updated: 2015-06-25 17:46

Dependencies (7)

Required by (0)

Sources (2)

Latest Comments

jhsnyder666 commented on 2015-03-19 19:52

git branch develop compiles.

jhsnyder666 commented on 2015-03-19 19:04

Not able to compile either the branch at NRL or the branch at github.

Looks like it's the ace headers. The guy sitting next to me compiled on ubuntu 12 with gcc 4.7 and ace 6.0.something.

I have gcc 4.9 and ace 6.3.1-1.

Will check with the instructor when there's a break.

jhsnyder666 commented on 2015-03-19 16:01

FWIW, I had to run autoreconf to build from the SVN... the package doesn't include a bootstrap, and it's hard-wired for automake-1.13, which is old enough that it's not in my package cache (

Also ./configure sets eg ACLOCAL to:

ACLOCAL='${SHELL} /path/to/emane/missing aclocal-1.13'

but doesn't throw an error, so you don't know that anything has gone wrong until you run make install.

I'm in a workshop with the developers this pm, so if you have any questions or run into a problem with the build, let me know and I'll ask them.

jhsnyder666 commented on 2015-03-19 14:24

I am about to start using it, and I will probably have to track the SVN, so if you can bring the PKGBUILD up to date, I can maintain it.

tom5760 commented on 2015-03-19 14:11

Hey jhsnyder666, yes I haven't actually used emane in some time. Are you actively using it? Would you be interested in maintaining the PKGBUILD? Either way, I can try to get this up to date later today.

jhsnyder666 commented on 2015-03-19 14:00

PKGBUILD seems out of date... makepkg complains about the lack of a package() function.

Current emane version is 0.9.2-r1