Package Details: emby-server-beta 3.4.1.32-1

Git Clone URL: https://aur.archlinux.org/emby-server-beta.git (read-only)
Package Base: emby-server-beta
Description: Bring together your videos, music, photos, and live television
Upstream URL: http://emby.media
Keywords: emby htpc media server
Licenses: GPL2
Conflicts: emby-server
Provides: emby-server
Submitter: nottin
Maintainer: nicolahinssen
Last Packager: nicolahinssen
Votes: 4
Popularity: 0.421437
First Submitted: 2016-07-23 17:42
Last Updated: 2018-07-12 19:34

Latest Comments

nicolahinssen commented on 2018-05-15 19:01

zifnab:

Ah great! That package didn't exist when I checked for the last time. Update will be online in a few mins!

zifnab commented on 2018-05-15 18:44

the aur has this: dotnet-runtime-rc 2.1.0-1 making it a dependency would replace the official community package dotnet-runtime 2.0.7-1 wouldn't it? you can revert the dependencies to "official" package once it upgrades to 2.1.0+

using aurman as an aur helper: aurman -S dotnet-runtime-rc does the job, and the new emby-server starts.

nicolahinssen commented on 2018-05-14 19:22

zifnab:

Yes, I know. I'm currently looking for a solution.

The problem is caused by the "dotnet-runtime" (https://www.archlinux.org/packages/community/x86_64/dotnet-runtime/) package still being on version 2.0.7, while Emby requires .NET Core 2.1 RC1 since 3.4.1.2...

If someone has any possible solution, please let me know!

zifnab commented on 2018-05-14 18:46

3.4.1.4 fails to start. looks like a dependency issue.

'journalctl -xe' output:
"...
It was not possible to find any compatible framework version
The specified framework 'Microsoft.NETCore.App', version '2.1.0-rc1' was not found.
..."
'pacman -Qi dotnet-runtime' output: 2.0.7-1
regards.

BlownFuze commented on 2018-03-01 13:22

Thank you nicolahinssen, I went ahead and cleared my cache anyway - update went through without any errors. All good now.

nicolahinssen commented on 2018-03-01 01:45

BlownFuze:

That's because makepkg uses the cached (mismatched) embyserver-netcore-3.3.0.3.zip archive on your system. Remove this .zip file from your cache folder (e.g. ~/.cache/pacaur/emby-server-beta/embyserver-netcore-3.3.0.3.zip) and try again.

EDIT: Nevermind, the problem was on my side. It has been solved in the update I just uploaded.

BlownFuze commented on 2018-02-28 12:53

Thank you, same error though. It's not a big deal, I can just wait for the next incremental version - they seem to be releasing minor updates almost everyday.

==> Making package: emby-server-beta 3.3.0.3-2 (Wed Feb 28 12:45:55 EST 2018)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found embyserver-netcore-3.3.0.3.zip
  -> Found emby-server
  -> Found emby-migrate-database
  -> Found emby-server.conf
  -> Found emby-server.service
  -> Found emby-server.sysusers
  -> Found emby-server.tmpfiles
==> Validating source files with sha256sums...
    embyserver-netcore-3.3.0.3.zip ... FAILED
    emby-server ... Passed
    emby-migrate-database ... Passed
    emby-server.conf ... Passed
    emby-server.service ... Passed
    emby-server.sysusers ... Passed
    emby-server.tmpfiles ... Passed
==> ERROR: One or more files did not pass the validity check!
:: Unable to build emby-server-beta - makepkg exited with code: 1

nicolahinssen commented on 2018-02-28 02:56

BlownFuze:

Thanks for letting me know. I've pushed an update, could you try it again?

BlownFuze commented on 2018-02-28 01:53

Not sure if I'm missing something, but this is the first time I've had a problem updating. The main netcore zip won't pass the validation.

==> Validating source files with sha256sums...
    embyserver-netcore-3.3.0.3.zip ... FAILED
    emby-server ... Passed
    emby-migrate-database ... Passed
    emby-server.conf ... Passed
    emby-server.service ... Passed
    emby-server.sysusers ... Passed
    emby-server.tmpfiles ... Passed
==> ERROR: One or more files did not pass the validity check!
:: Unable to build emby-server-beta - makepkg exited with code: 1

nottin commented on 2017-02-16 02:10

brando56894:
Should work now.
The reason it didn't work before is because the beta was updated.
If you see this again, simply flag the package as out-of-date, and I'll update asap.

All comments