Package Details: emotion_generic_players-git 1.17.99.141.g2853260-1

Git Clone URL: https://aur.archlinux.org/emotion_generic_players-git.git (read-only)
Package Base: emotion_generic_players-git
Description: Emotion external binary executable players - Development version
Upstream URL: http://www.enlightenment.org
Licenses: BSD
Conflicts: emotion_generic_players
Provides: emotion_generic_players=1.17.99.141.g2853260
Submitter: Scimmia
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 8
Popularity: 0.785178
First Submitted: 2013-03-01 17:10
Last Updated: 2016-03-25 16:23

Latest Comments

Scimmia commented on 2015-10-17 05:32

Your efl-git is too old.

Reded commented on 2015-10-16 23:36

Hi, got this error when trying to build this:

checking for EMOTION... no
configure: error: Package requirements (emotion >= 1.16) were not met:

Requested 'emotion >= 1.16' but version of emotion is 1.14.99.30727

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EMOTION_CFLAGS
and EMOTION_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Am I missing something here?

Scimmia commented on 2013-06-22 06:54

Sync with upstream pkgbuild, but nothing major changed.

Scimmia commented on 2013-04-05 03:37

This package how now been updated for pacman/makepkg 4.1. It will no longer work with makepkg 4.0.3 or earlier.

If you've built this package before, it's best if you remove the existing "src" dir to make sure everything's clean, but it's not required. Either way, the new version will re-download the source.

You'll notice that the pkgver has changed significantly. If you're using an AUR helper that tries to check the package version to see if it needs to rebuild, it won't like this so please reinstall this package manually. Going forward, though, this scheme should work much better with those AUR helpers. I could add an epoch to the PKGBUILD, but then we'd be stuck with it forever. Since this should be a one time thing, I think it's better to just ask people to install.

Scimmia commented on 2013-03-01 17:12

*** Critical ***

Enlightenment is in the process of switching from svn to git and this program has now been switched. Please switch to the git version of this package as soon as possible.

https://aur.archlinux.org/packages/emotion_generic_players-git/

TUs: Please don't delete this package until I ask you to. In the AUR, people need to see that a package has been replaced and manually make the switch themselves so this notice needs to be here for a while.

Scimmia commented on 2013-03-01 05:41

You know, I just realized that I never added instructions here on how to use this module. I mentioned it in the comments for EFL, but it should really be here. Currently, Emotion will use the first module it finds, which is usually the built-in gstreamer one. In order to use this VLC module, you need to rebuild efl-git without the gstreamer plugin (and the xine plugin, which is already disabled by default) so that this is the first one it finds. To do that:

1. Remove 'gstreamer0.10-base-plugins' from the dependencies
2. Add --disable-gstreamer to the autogen.sh command. Remember that you need "\" at the end of each line except the last one.

Scimmia commented on 2013-01-11 05:03

It was decided to use a separate package for external modules for Emotion, similar to the way they do with Evas (evas_generic_loaders). Currently, it contains a module for VLC. The Gstreamer backend that's built into Emotion is usually enough, so this package is completely optional.