Package Details: emptyepsilon 2017.05.06-1

Git Clone URL: https://aur.archlinux.org/emptyepsilon.git (read-only)
Package Base: emptyepsilon
Description: Open source spaceship bridge simulator
Upstream URL: https://github.com/daid/EmptyEpsilon
Licenses: GPL2
Submitter: mewp
Maintainer: mewp
Last Packager: mewp
Votes: 5
Popularity: 0.377134
First Submitted: 2016-05-12 17:10
Last Updated: 2017-05-27 08:46

Latest Comments

mewp commented on 2016-10-27 19:57

Sorry. That's fixed now.

Leo_Verto commented on 2016-10-27 18:02

I think you forgot to update fixed-version.patch to the latest version, the game showed the wrong version ingame and was unable to connect to servers of the latest version.

Changing the line "string(TIMESTAMP CPACK_PACKAGE_VERSION_MINOR "06")" to "string(TIMESTAMP CPACK_PACKAGE_VERSION_MINOR "09")" fixed this.

Frnmst commented on 2016-06-12 15:12

Sorry, my mistake.

Since I am not using an AUR helper anymore, what I did was to download only the PKGBUILD and not the snapshot (which has got fixed-version.patch file).
Now it works perfectly. Thank you for your help.

mewp commented on 2016-05-30 11:03

Um, but the file isn't missing. Try downloading the snapshot and checking.

Anyway, this patch is practically necessary for multiplayer, because clients report their versions to the server, and by default, the version is the compilaiton date. The patch sets it to the release date, so that you can play with people who didn't compile EE the same day as you did.

Frnmst commented on 2016-05-29 23:24

Hello,

In order to build the package (version with git tag EE-2016.05.22) I modified the prepare function like this, since a file is missing:

prepare() {
:
# patch -Np1 < ../fixed-version.patch
}

Having done that I had no more problems on building and running the game on Parabola GNU/Linux-libre. Moreover, all dependencies are free software.