Package Details: encfs18 1.8.1-10

Git Clone URL: https://aur.archlinux.org/encfs18.git (read-only)
Package Base: encfs18
Description: Encrypted filesystem in user-space (without issue #214)
Upstream URL: https://vgough.github.io/encfs/
Licenses: LGPL
Conflicts: encfs
Provides: encfs
Submitter: m13253
Maintainer: Edlmann
Last Packager: Edlmann
Votes: 1
Popularity: 0.000005
First Submitted: 2016-09-27 13:11
Last Updated: 2017-05-30 16:32

Required by (22)

Sources (2)

Latest Comments

Edlmann commented on 2017-05-30 16:35

Feared as much with the package not being updated :) Alright thanks, just pushed the fix. Not sure I'll be maintaining the package much more though.

m13253 commented on 2017-05-30 15:38

@Edlmann
Thank you for your backport.
But sorry I don't use ArchLinux any more, being unable to test your patch.
I added you to the co-maintainer list, so you should be able to modify the PKGBUILD.
If you have any problems, please let me know.

Edlmann commented on 2017-05-30 11:35

Package doesn't build since openssl udpate to 1.1.

I backported the openssl-1.1-patch from the main repo (https://git.archlinux.org/svntogit/community.git/tree/trunk/encfs-openssl-1.1.patch?h=packages/encfs):
https://gist.github.com/anonymous/8a35da9db23e1168c4a8626099a77e6a

Once that patch is applied it builds fine and #214 (which happens after ~5min for me with normal encfs) doesn't seem to be affected.

Would be nice if you could review + add it to the repo

sdjd commented on 2016-10-15 19:50

Sorry, it was my fault. I've rebuilt encfs18 with latest boost-libs already installed and it's running okay now.

sdjd commented on 2016-10-15 13:44

Okay, I've tested in VM. Haven't encountered that lib issue, so it's definitely has something to do with my main Arch installation. Gonna investigate further.

m13253 commented on 2016-10-13 01:31

My boost-libs is also 1.61.0-2, but I can not reproduce your error.

m13253 commented on 2016-10-13 01:30

@sdjd

I'm sorry to hear that.
Have you considered to set up a VM to do the experiment, and then report the problem to the upstream?

sdjd commented on 2016-10-12 21:14

No, I meant boost-libs 1.61.0-2 in [extra]. I'm not sure I should notify anyone, when encfs-1.9-2 starts okay(#214 issue aside) with current boost-libs in [extra].

But when I try running encfs18 with boost-libs 1.61.0-2 I get lib errors. Sorry, but right now I can't provide you with log since I don't want to mess with my encrypted $HOME.

m13253 commented on 2016-10-09 16:22

@sdjd
Do you mean boost-libs-1.62.0 ?
Sorry I do not use the [staging] repo, and I have no idea about the compatibility problem.

Is there any backport patches? Is the upstream notified about the compatibility break?

sdjd commented on 2016-10-09 16:14

Thanks for tackling the issue, but this package has the same problem as encfs pre 1.9-2 - not working with new boost-libs package. And no upgrading boost-libs causes problems with other packages. Is it possible to make it compatible?

I hope issue #214 will be resolved quickly.