Package Details: endless-sky 0.9.12-2

Git Clone URL: https://aur.archlinux.org/endless-sky.git (read-only, click to copy)
Package Base: endless-sky
Description: A space exploration and combat game similar to Escape Velocity
Upstream URL: http://endless-sky.github.io/
Licenses: custom:public domain, GPL3, CCPL
Submitter: alcasa
Maintainer: grawlinson
Last Packager: grawlinson
Votes: 20
Popularity: 1.16
First Submitted: 2017-04-12 11:33
Last Updated: 2020-05-17 07:20

Latest Comments

grawlinson commented on 2020-05-16 09:15

Thanks for that, bitfreak! I'm encountering this issue with some other packages.

It'll be because gcc 10 has changed header dependencies. I've filed a bug report upstream.

I'll also add a patch to this package soon.

EDIT: Patch added. Enjoy! :)

bitfreak commented on 2020-05-16 06:52

The package doesn't build with the following error:

source/Panel.h:97:25: error: 'string' in namespace 'std' does not name a type
97 |  bool DoHelp(const std::string &name) const;
   |                         ^~~~~~
source/Panel.h:22:1: note: 'std::string' is defined in header '<string>'; did you forget to '#include <string>'?
21 | #include <SDL2/SDL.h>
+++ |+#include <string>
22 |

Eventually due to the new gcc10? I've added the missing #include and it builds fine. So a simple patch could probably fix that. (also maybe upstream needs it)

grawlinson commented on 2020-03-01 07:34

Tharbad: I'm fairly certain that you've downloaded the archive, and curl is subtly hinting for you to delete the broken download (due to the site not supporting resume).

turgid: Done.

Tharbad commented on 2020-02-28 00:37

Deleting $pkgname-$pkgver.tar.gz:: from line 16 allowed me to solve "curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume. ==> ERROR: Failure while downloading https://github.com/endless-sky/endless-sky/archive/v0.9.11.tar.gz Aborting..."

turgid commented on 2020-01-30 12:14

Please change build command to

scons -j`nproc`

The build is very slow without this and only uses one core.

grawlinson commented on 2019-01-04 22:58

Have adopted this package, I’ll push some fixes after work today.

DragonMaus commented on 2019-01-04 02:32

This package is still missing the libpng dependency, as adsun pointed out six months ago.

grawlinson commented on 2018-08-29 01:15

Cleaned up the package a bit. This patch should help out.

  • remove($pkgname.install): not necessary anymore
  • remove(dependencies): git, xdg-utils
  • add(dependencies): add hi-dpi & editor optional dependencies
  • refactor(build): no need to gzip manpage, makepkg does this via hooks
  • refactor(package): add extra icons (128, 512px)

adsun commented on 2018-07-01 18:16

Please add libpng to depends.

Distag commented on 2017-06-26 09:18

Add libmad as dependencie