Package Details: enigma2 20140610-1

Git Clone URL: (read-only)
Package Base: enigma2
Description: Enigma2 - software for Linux-powered DVB satellite, terrestrial and cable digital television receivers (e.g. Dreambox). This is experimental version for PC.
Upstream URL:
Licenses: GPL2
Submitter: None
Maintainer: None
Last Packager: knedlyk
Votes: 1
Popularity: 0.000000
First Submitted: 2011-07-26 10:20
Last Updated: 2015-06-23 21:28

Latest Comments

technic93 commented on 2015-01-13 12:28

for giflib 5.1.0 I need some more patching

diff --git a/enigma2/lib/gdi/picload.cpp b/enigma2/lib/gdi/picload.cpp
index be8f4bb..3e5429b 100644
--- a/enigma2/lib/gdi/picload.cpp
+++ b/enigma2/lib/gdi/picload.cpp
@@ -538,7 +538,7 @@ static void gif_load(Cfilepara* filepara)
int cmaps;
int extcode;

- gft = DGifOpenFileName(filepara->file);
+ gft = DGifOpenFileName(filepara->file, NULL);
if (gft == NULL)
@@ -609,11 +609,11 @@ static void gif_load(Cfilepara* filepara)

- DGifCloseFile(gft);
+ DGifCloseFile(gft, NULL);
eDebug("[Picload] <Error gif>");
- DGifCloseFile(gft);
+ DGifCloseFile(gft, NULL);


elpadre commented on 2012-01-16 20:28

I launch enigma2 as an mms script and it does not really take the whole screen but more like 50% starting from the top-left corner
I have the same problem with mplayer but there I use --geometry 1920x1080+0+0 and problem solved.
Can not do that with enigma2 so I am in a bit of a pickle.

elpadre commented on 2011-11-23 07:38

I got enigma2 to install with:
pacman -R python
Install with makepkg from AUR libnl-2
yaourt -S enigma2

elpadre commented on 2011-11-22 18:46

I removed python 3.2 (I had both 3.2 and 2.7)

so a new error (non python related) with yaourt -S enigma2

Thanks in advance for your help

elpadre commented on 2011-11-22 12:20

anyways, I´ve let yaourt install the linux-headers and still Enigma2 didn´t work

Here is the error log, hope you can help:

elpadre commented on 2011-11-22 12:14

Well, I tried yaourt, trouble is that it wants to install linux-headers but I am using kernel 2.6.34-7 as the 3.x kernels break my remote control
I have kernel2 headers installed instead
so if I remove the linux-hearders requirement, would the experiment still have value for you?

Anonymous comment on 2011-11-20 23:45

Media Player is improving, began to work the video control buttons:
1 button 10 second back
2 button pause
3 button 10 second fw
4 button 1 minutes back
5 button resume
6 button 1 minutes fw
7 button 10 minutes back
8 button fast fw
9 button 10 minutes fw

elpadre commented on 2011-11-20 16:03

I got the dependencies in place but makepkg fails with enigma2:

checking consistency of all components of python development environment... no
configure: error: in `/usr/local/src/enigma2/enigma2/src/Enigma2PC-build':
configure: error:
Could not link test program to Python. Maybe the main Python library has been
installed in some non-standard library path. If so, pass it to configure,
via the LDFLAGS environment variable.
Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
You probably have to install the development version of the Python package
for your distribution. The exact name of this package varies among them.

See `config.log' for more details

config.log :

configure:3880: checking dependency style of gcc
configure:3990: result: gcc3
configure:4011: checking how to run the C preprocessor
configure:4042: gcc -E conftest.c
configure:4042: $? = 0
configure:4056: gcc -E conftest.c
conftest.c:9:28: fatal error: ac_nonexistent.h: No such file or directory
compilation terminated.
configure:4056: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "enigma2"
| #define PACKAGE_TARNAME "enigma2"
| #define PACKAGE_VERSION "3.0.0"
| #define PACKAGE_STRING "enigma2 3.0.0"
| #define PACKAGE_URL ""
| /* end confdefs.h. */
| #include <ac_nonexistent.h>
configure:4081: result: gcc -E
configure:4101: gcc -E conftest.c
configure:4101: $? = 0
configure:4115: gcc -E conftest.c
conftest.c:9:28: fatal error: ac_nonexistent.h: No such file or directory
compilation terminated.
configure:4115: $? = 1

Anonymous comment on 2011-11-13 22:53

A good news - the media player is works!

Anonymous comment on 2011-08-31 23:41

This is experiment initiated by the turkish programmer - I just adapted the project for the Arch, and encourage all depends. It works only with libvdpau for Nvidia cards installed.

All comments