Package Details: eolie 0.9.15-1

Git Clone URL: https://aur.archlinux.org/eolie.git (read-only)
Package Base: eolie
Description: Simple web browser for GNOME
Upstream URL: https://gnumdk.github.io/eolie-web/
Keywords: browser gnome web webkit
Licenses: GPL3
Submitter: City-busz
Maintainer: gnumdk
Last Packager: gnumdk
Votes: 9
Popularity: 2.999889
First Submitted: 2017-07-14 13:18
Last Updated: 2017-12-04 16:13

Latest Comments

gnumdk commented on 2017-11-05 17:51

Looks like a driver issue, does it happen with Epiphany?

Try running:
WEBKIT_DISABLE_COMPOSITING_MODE=1 eolie

fabrixx commented on 2017-11-05 17:36

Browser start but have a WebKit error when pages are loaded:
(The webpage was terminated unexpectedly.To continue, reload or go to another page.If problem persist, you can report a bug :)Use 'Webkit Gtk' as component.Set [GTK] as subject prefix)

From terminal:
(WebKitWebProcess:5515): Gdk-ERROR **: The program 'WebKitWebProcess' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
(Details: serial 197 error_code 2 request_code 154 (GLX) minor_code 34)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the GDK_SYNCHRONIZE environment
variable to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

donpollo commented on 2017-10-31 11:23

python-dateutil dependency seems to be missing.

Output when trying to run eolie without it:

Traceback (most recent call last):
File "/usr/bin/eolie", line 25, in <module>
from eolie.application import Application
File "/usr/lib/python3.6/site-packages/eolie/application.py", line 28, in <module>
from eolie.window import Window
File "/usr/lib/python3.6/site-packages/eolie/window.py", line 16, in <module>
from eolie.toolbar import Toolbar
File "/usr/lib/python3.6/site-packages/eolie/toolbar.py", line 16, in <module>
from eolie.toolbar_title import ToolbarTitle
File "/usr/lib/python3.6/site-packages/eolie/toolbar_title.py", line 20, in <module>
from eolie.popover_uri import UriPopover
File "/usr/lib/python3.6/site-packages/eolie/popover_uri.py", line 18, in <module>
from dateutil import tz
ModuleNotFoundError: No module named 'dateutil'

City-busz commented on 2017-10-31 09:37

@gnumdk:
You can adopt it now.

gnumdk commented on 2017-10-31 09:30

Yes, until someone want to package this :-) (lollypop packager maybe)

City-busz commented on 2017-10-31 08:58

@gnumdk:
I don't have too much time. I see that you are the developer. Would you like to adopt it?

gnumdk commented on 2017-10-31 08:54

@City-busz
Do you always have time to maintain the package?

twa022 commented on 2017-10-19 11:46

I added a package for pyfxa: python-pyfxa, can you please add as a dependency or optional dependency for firefox sync integration.

zobi8225 commented on 2017-08-22 08:43

If you want to sync with firefox you need to install pyfxa :

sudo pip install pyfxa